Clearing Clipboard

Is there an easy way to clear the Libreoffice clipboard?

I have been having trouble clearing the LibreOffice clipboard, which appears to be different from the Windows clipboard (which I can clear). I frequently have to close and restart the program to clear the LibreOffice clipboard.

I have searched (Google) and see others have had the same or similar problems since OpenOffice but no answers seem available. I have been using OpenOffice (and now LibreOffice) for many years and think the issue many be more consistent in the past few updates.

Is this a “Bug” or a “feature”?


No, I have tried that. Even tried copying a couple of blank spaces. Then the blanks occupy the clipboard. So, if I, say, copy a link from a browser, or text from a text editor and try to paste to a document I only get the blank or blanks. From here my only solution seems to be exit LibreOffice, restart it, open the document I am working on and then copy and past from outside LibreOffice. This works until the next time I copy from within Libreoffice.

I experience the same behavior on at least 3 machines with various flavors of Windows OS

So, it is a “feature”?

Actually it is a bug. Unofficial one. I found this on the Bugzilla site. if you are experiencing similar difficulty please go there and comment on it.Bug 62196 - EDITING: copy-paste from non-LibO-text-source pastes previous clipboard contents (edit)

So, am I/are we stuck with this???

1 Like

Doesn’t selecting a space or empty cell and copying that effectively “clear” the clipboard?

That wa a great suggestion.

It seems that Libre Writer changes to some sorts of internal Clipboard as soon as text is copied between 2 writer documents. Once stuck inside its own clipboard it becomes impossible to copy/paste between writer and external programs. The workaround that works for me (Windows 8 - Libre is to select a space within Writer, followed by CTRL+C, then CTRL+V.
This action points Writer’s clipboard back to the normal windows clipboard.

Hope this helps other users with the same problem.

Hey, could you try it with 4.2.2 and if it’s still present please write a bug report with instructions on how to trigger this. Unfortunately I don’t have windows 8 so cannot test it.

This should be marked as the answer - just verified with Windows 8 and a recent version of LibreOffice.

Sorry to say, this procedure does not fix it for me. It seems my problem is caused, at least in part, by the remote access software I currently use, Screenconnect. I still either have to close out of one program or the other to clear the issue. And, it seems, there are other clipboard using programs that will also cause the problem.

I have brought this to the attention of both LibreOffice and Screenconnect and apparently given them both a good excuse to ignore it. After all it is “the other guys” problem :frowning:



Isn’t the clipboard an OS functionality?

GTK+ libraries have their own implementation of clipboard which is synced with Windows clipboard, but in some conditions it breaks. And tools which work with Windows’ clipboard, doesn’t necessarily know how to interact with GTK+.

@mahfiaz - thanks for explanations!

Any chance of the fine folks at GTK+ letting the other folks know what they need to play well together?