Clicking vertical scroll bar in Writer jumps to position, not 1 page

Standard behaviour in MS Word & basically all programs is that, starting from the top, clicking any of the blank scrollbar area below the scrollbar’s slider causes the view to jump 1 screen down. Ditto going upwards. In Writer, it jumps to that place in the document. This isn’t inherently wrong, per se, but it’s unintuitive since it’s the only program that does it this way, to my knowledge, and I can’t unlearn my expectations. I’ve looked but can’t find an option to switch to classic behaviour, is there such an option?


Build ID: 1:5.1.1~rc1-0ubuntu1~wily1
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default;
Locale: en-GB (en_IE.UTF-8)

EDIT by @ajlittoz:

This is a screenshot on how all the scrollbars look like (Fedora 24, Linux 4.7.7, KDE 5, LO 5.2)

This is a real annoyance for the text but also an inconvenience in the panels (style and navigator)

Same behaviour under Fedora 22-23-24. I thought it was some configuration issue in my OS because I activated Wayland. This behaviour is the bare X one (without layer like GTK or Qt). Moreover, my scrollbars lack the “single line” controls at top and bottom.

To sharky-pi and ajlittoz:
Are you both using GNOME? I could not replicate this behaviour neither on Mac (10.9.5) LO ( nor on Ubuntu (16.04 LTS/Unity) LO ( But I found this link on regarding this exact same thing not only in LO but also in Firefox.

I’m using KDE but exact same symptoms as in the link both in LO and Firefox, which I did not mention. Worse, Firefox does not retrieve the cursor theme and uses a default one. I thought it was related to the deep changes brought by Wayland. LO and Firefox are “universal” applications, meaning they do not use directly Gnome or KDE libraries to be able to run in any environment without dependencies. Maybe its private libs do not take into account the latest changes.

I believe that the LibreOffice Navigator is one of its best kept secrets and although it does not exactly answer your question, it is thoroughly worth exploring for any longer document.

LibreOffice provides the Navigator to help find your way around a document. If I simply wish to ‘page up’ or ‘page down’ I tend to use the keys marked as such. For more complex documents I use the LibO Navigator. It can be invoked by using PF5, PF11 and select the Navigator icon or clicking on the page number on the bottom of the screen. Using the Navigator you can move through the document by page number, styles, images, headings, sections, hyperlinks etc
When the Navigator is displayed, you can simply page through the document page by page. I should try it.

I agree with the usefulness of the Navigator but the scrollbars are also a good feature: you can temporarily examine another area of the document without losing cursor position. To go back, I just type “line up”-"line down’.

Great question! Is there no answer? I have the “behavior” (read: problem - no other window on my system works this way, and I (try to) use the scroll bars to scroll down the viewable screen page. I keep missing huge sections of documents - it’s very confusing. I’m not opening a new question, because my question is the same - but maybe no one will see or answer this question.
Please help. Thanks.


Is there some other method to bring an un-answered question to attention? If @dgbutterworth only added comment this would have continued un-noticed. At least he searched for answer before posting a question, found un-answered question and the added answer to bring some attention. Maybe its possible to add and then delete an answer to bump a question, but not sure how a new user could know this.

Can not confirm your behavior of Writer. Jumps page up/down. LO 5.1.5 and 5.2.2 Win10.

May be different in Ubuntu???

Try resetting your user profil, worked on many weird behaviors.

Same here - no problem in Windows 10.

I had the same problem on Linux, using the XFCE desktop. It went away when I did a LO upgrade, uninstalling the old version first. Something in the previous install was hanging it up.

Mine is a fresh install in a dedicated partition but the /home is shared with the “production” system partition. Do you hint that some sort of ~/.config needs to be reset? But then, how to keep the configuration customisations (templates for examples) in the “production” state?

FWIW OpenOffice does not behave this way: click either side of the slider moves the document a screen up or down just like other Windows apps do. Oh, how I wish LO were fixed or an option provided to allow the same behaviour.