Clone formatting is not working for me

I’m using LO v. 6.2.3.2(x64). I am editing a long document in which the font is mostly 12 point, but there are some lines that are 11 point. I’ve set the default font to 12 point. Here are my problems:

  1. If I select the 11 point text and click on default font, the size of the font does not change.
  2. If I select text in 12 point font, click the clone formatting tool, then select 11 point text, the size of the 11 point font does not change.
    I’ve tried holding down Ctrl when I clicked the clone formatting tool, but still no change. According to the help file, this shouldn’t be necessary, but I’m grasping at straws.
    Any ideas?
    Thanks.

This is one of the issues I’m struggling with in moving from MS Word - I am used to clone formatting working perfectly. In writer I can get it to work partially if I remember to also hold CTRL, but even then it often ignores some element e.g. a font change, so it still doesn’t copy all the formatting. If you’re just trying to make one pasted in paragraph look the same as what’s around it, this can be infuriating!

The answer below, about styles, is obviously a good way to create a proper document. It is what I do for anything important. However, often I WANT to create a quick and dirty doc - maybe an FAQ copied from the web, or a list of specs for some hardware. I don’t need it to be in my styles, just look consistent. But whereas cone formatting in MS Word does that exactly as it should, in LOWriter it often ignores elements like fonts (even if you hold CTRL). It makes moving from MS Word to LO a lot harder than it should be.

Your approach is called hard formatting (fast and dirty). It is used for small documents when it needs to be done quickly.

A durable good formatting can be achieved with styles. For each text that should be different, a style template must be created once. Then you need to put unformatted text per paragraph only once the cursor and double-click the desired style. How to do that you can look here a video.
In LibreOffice you can access the style sheets in the sidebar (Ctrl + F5).

Text that does not want to be changed, you should first mark and select in the menu Format>Clear Direct Formatting. You can also mark the whole document and then delete the formatting. Then you can reformat each paragraph with a desired style.

I wish you success!

If my answer did solve your problem, please click the big checkmark inside the circle image description to the left of this answer. It then indicates to the other participants that the question has been answered correctly.

With me Windows 10 Home; Version 1809; 64-Bit | LibreOffice, Version: 6.2.4.2 (x64).