Concordance File and persian language

  1. I have written a Concordance file.
  2. I choosed Insert ==> Table of Contents and Index ==> Table of Contents, Index or Bibliography – Type ==> Type box ==> "Alphabetical Index ==> Persinan Language
  3. In Options area ==> the Concordance file ==> edit file
  4. A table apeared. The Charcter in the table are change and are not more persian character. I deleted these characters and write again the entries in persian language.
  5. I refresh my TOC. But it apears nothing, no resault.
  6. I see again the Concordance File and the table. The persian charachers are changed again. I see only the characters of question marks like: ???

How can I use Concordance File in persian language?


The ??? are an indication of an issue about file encoding. How did you create your concordance file? From inside Writer or with an external text editor? How did you save it (which file extension)? Are you sure you saved it as a Unicode encoding and not ISO-8859-6 or other national standard?

Edit your question to provide more technical details, not omitting OS name and LO version.

Please do not use Add Answer but edit your original question to enhance the details of your question (answers are reserved for solutions to a problem on this Q&A site).

There are two possibilities to create a concordance file: 1- from inside Writer; 2- with an external text editor. I have used these two possibilities.

  1. I mean of inside Writer editor:
    Insert → Table of Contents and Index → Table of Contents, Index or Bibliography – Type → Type box → "Alphabetical Index → active concordance file → “Edit”.

  2. The inside Writer Editor has no option to choose character encoding. I have written my index entries and saved the file. When I open the concordance file, I see only question mark: ???

  3. I use “notepad++” editor and save the file with “utf-8” or “utf-8 without BOM” or “arabic ISO-8859-6”. I see nothing with run the index of LO.

  4. When I open the file with LO inside Writer, I see only some unnormal character.

  5. The concordance file is: “concordPersian.sdi”


When created from inside Writer, there shouldn’t be any encoding problems. The file must be Unicode (utf-8 is OK) but not ISO-8859-6.

It is correct and work with LO of Version: but not Version: 6.0.7.
I have two Version.
Thank you.

I have created some index entries with the dialog window (insert > Table of Contents and Index > Index Entry).
can I see these index entries with a file like concordance file or in a table?

Do you mean yoou want to check file concordance content? The .sdi file is a plain text file. Open it in NotePad. Getting the file content in a Writer table is more complicated.

There are two ways to create index entries, either via the concordance file or manually using the dialog box. I select (Insert > Table of Contents and Index > Index Entry) to bring up the dialog box.

I would like to know if there is a way to see my entries that I created manually with this dialog box in a file like the concordance file or in a table?

Open the corresponding file in NotePad.

Have you set the LibreOffice file (.odt) to understand Persian? TOOLS > OPTIONS > LANGUAGE SETTINGS > LANGUAGE > COMPLEX TEXT FORMAT > PERSIAN.

If you have a � (fffd-alt/x) Character your editor does not support Persian.
Why are you using .sdi? This is not a LibreOffice file type.

1- I mean by dialog box, this box is in the following image.

Insert Index Entry

I would like to know whether there is a file or a table in which I can see, edit and save my all entries.

2- yes I Have set the LibreOffice file (.odt) to understand Persian.

@petermau: .sdi is the extension used by Writer when creating the concordance file. This is perhaps a non-updated extension dating back to the time when .odt was .sxw (or similar, I don’t remember exactly) in the initial ODF format.

But as shown by experiment, .sdi has a plain text content, the same as .txt.

If the entries are not defined by a concordance file, there is no means to save them separately. There is no reason for Writer to insert a 1st key on its own if you don’t enter it yourself.

You “see” your entries when you insert the Alphabetical Index.

To edit your entries, right-click on one of thel and Index Entry, then use the “arrow buttons” to navigate to other entries.