conditional hide text problem

I have LO, VCL:gtk3, UI:en-US on a MX Linux 19.4, I’m trying to hide some text from my document, I could hide text in other part of the same document, but not in this particular place, not sure where is the problem, this is what I’m trying to do: variable name num_inqui, if it’s “1”, I’d like to hide the text, I created the variable as shown in the following picture

and the condition as seen here

it seems the text is always hidden no matter what I put in the variable, what am I missing?

Please edit your question (don’t use “Add Answer” which is reserved for solutions) to tell if you want to hide a full paragraph, only part of a paragraph or insert conditionally some text. As you show the dialog, you have chosen the conditional text option and provided empty strings in both cases. This is not the tool to hide existing text in the document.

Thanks @ajlittoz for this tip, solved the problem using sections.

I reopened the question so that you can post an answer. I am very intrigued by a section solution. In Writer, sections are parts of a page with a different layout. So they are not usual solutions to formatting issues. Please explain how you did it, others may benefit for your solution.

I would personally have gone for hidden paragraphs (depending on a condition).

As suggested, this is not answer for OP, I’m using hide section option, basically I followed the instructions from this post and the steps I took is as follows:

  1. create a variable (I tried to use General type of variable, but didn’t have a lot of luck, used Text instead)
  2. duplicated the paragraph where the text I want to hide is located (so paragraph 1 with hidden text and paragraph 2 without hidden text), highlighted the whole paragraph(s), went to menu > Insert > Section > on the Section tab change Section1 to a name relevant to your paragraph > on the right pane, under Hide, check Hide box (I prefer to check this box after I finished my editing, but you need to check the box to enter the hide formula, after uncheck again for testing) then enter the formula/condition to hide the paragraph > click Insert.

OK, I see.

Using hidden sections is a good idea when you have a lot of contiguous paragraphs to hide as a whole. This simplifies formatting where you control the whole sequence from a single spot.

The more common hidden paragraph feature is right when you have a single paragraph to hide in the middle of always-shown paragraphs.

Your answer is indeed a solution to the problem. I’ll check it when the watchdog timer allows me to do it. I don’t remember if your karma is high enough for you to accept your own answers.

I’m not sure, it seems to me that hide paragraph/text is not very consistent, tried few times using it, sometime works sometime not, besides sections, as you said can have different formatting/style, which text does not allow.

Hide paragraph/text is consistent. The problem is rather frequently is the conditional expression. You must be very careful on them.

I see now.
I accidentally put in a Date_Detail=“Day” in a conditional text (instead of EQ or ==), and duplicated that mistake through the document.
I had had also created a set value field above that, setting it to “Month”.
The single equal sign in the condition field of the conditional text dialog box changed the value for the rest of the document. So, only the first instance in the document appeared to work properly.

That result isn’t what most people would expect. It would seem that a condition field should not be able to change the values of variables, but it can, and does.

Not only that, if you fix a condition that changes a variable in a conditional text, the rest of the document will not necessarily change until you change some text in the document (for example, put in an extra space, and take it back out).

That can be frustrating for people to try to figure out.