Connect LO Base to existing Firebird File

I am trying to connect LibreOffice Base (Version to Firebird 3.0 (Version LI-V3.0.7.33374).
I am running Ubuntu 18.04 and created the database with FlameRobin 0.9.3. The file is named “Test” and resides on ~/FirebirdDBS/Test1/Test.fbd.

I have tried in vain the following:

a)Start base and click “Connect to an exiting database (Firebird File)”->Next;

b)Browse to: “file:///home/fck/FirebirdDBS/Test1/Test.fdb” ->Next;

c)“Yes, register dbs + Open database for edit” ->Finish;

d)New window pops up requesting name for a .odb file! Save as “Test” on the default Home/196 dir. ->Save;

e)Error window pop up stating an error because the chosen fdb file exits! This is crazy because I am trying to connect to an existing file! See attached file for full error provided. Note: I did not install any funny extras. I presume that with the installation of LO, all requirements to connect to a Firebird DB would be included.

Please advise.
Please advise! Regards.Testfdb.jpg


Have seen various incidents when creating (maintenance seems OK) a DB using FlameRobin. Better to use isql for creation. Other than that, have had no problem in attaching Base to an external file. Just re-tested on Ubuntu 20.04 with LO v7.1.0.0 beta1 and had no problem. Have previously used this on Ubuntu 18.04 & Mint 19.

You state to see attached file but there is none. Full error message would probably be of help.

Sorry for the finger problem of omitting the error message. I did recreate the database and it was successfully created with iSQL, but the error remained. Can it perhaps a permission error? I chmod 7 the directory to 777 without success.Why is it stating it as an error that the flle exits?

Somehow I cannot get the picture file to be attached in a comment. Here is the message in text:
firebird_sdbc error:

*I/O error during "open O_CREAT operation for file “home/fck/FirebirdDBS/Test1/Test.fdb”

*Error while trying to create file

*File exists

caused by




It is a permissions problem. Did sudo chmod 777 Test.fdb and all was OK. Did notice in your isql you did not commit the table transactions.

Made some progress, but still a problem.
Just to be sure, II rebuild the Test database and it checked out OK:

I changed the permissions:
fck@fcTest:~/FirebirdDBS/Test1$ ls -l

-rwxrwxrwx 1 fck fck 688 Dec 1 13:34 Test1.sql

-rwxrwxrwx 1 firebird firebird 1597440 Dec 2 08:58 Test.fdb

-rwxrwxrwx 1 fck fck 1809 Dec 2 09:02 Test.odb

I then start LibreOffice as describe originally and it did proceed to the Base interface, but as soon as I clicked to show Tables, it popped up with the same “no connection error message”. I did discovered that the options for connection (Tools>Options>Base>Connections) was not checked. However, it made no difference, also when I set “Pool” to “yes” for firebird driver. Any other suggestions?

Do not know why all the problems and why all the various mods. My comment shows just the database from Firebird server needing a change in permissions (and probably not to the extent shown). Did my test just as you presented. At this point not even sure why you are not creating the file at the time you create a new Base file. New button is directly above Browse button. Sounds as if you are making things more complex than they need be.

A solution, well sort off. It became clear that something in Base got broken somehow. I could not even create a simple embedded database using HSQLDB! I completely (I hoped!) uninstall LibreOffice and reinstall it, but the problem remained. As it was a testing system, I reinstalled Ubuntu and LibreOffice and that solved the problem. Although I have many years experience in building databases with the ancient MS Access 2002 version, the lack of proper tools in Base to change simple things such as the table name, the data type, re-ordering of fields as well as effective data import methods and the clumsy suggested alternatives I found on website, was probably the cause. Access hide the complexity of SQL so well that you hardly ever need to use it. Maybe the user-friendliness of these simple things should get some attention – at least for users not so well versed in SQL.