Connecting to Mariadb with Libreoffice

I am trying to establish a connection between LibreOffice ( and Mariadb (10.1.29)/mysql. I have researched various resources on the web but am stuck not being able to establish a connection

preliminary steps taken:

  • the file mariadb-java-client-2.4.0.jar is downloaded from Connectors/java/connector-java-2.3.0/ - MariaDB
  • JRE is installed and enabled under LibreOffice Tools > Options > Advanced (according to the Mariadb connector page, only Java is required, not SDK)
  • in that Advanced tab, Class Path is set with mariadb-java-client-2.4.0.jar (I have tried with a path ‘/opt/mariadb-java-client-2.4.0.jar’ and ‘/home/user_name/mariadb-java-client-2.4.0.jar’)

Based on web site and youtube tutorials, the next steps are to connect via LibreOffice Base. Using the wizard:

  • Connect to an existing database MySQL is chosen from the dropdown
  • after clicking Next >>
  • Under some video and how-to tutorials, there has been a third option of “Connect directly…” Is this a further clue that something is not set properly?
  • I choose Connect using JDBC…and click Next >>
  • I provide the database name, the server (have tried localhost and and port number 3306
  • for the MySQL JDBC driver class I change the string to ‘org.mariadb.jdbc.Driver’ according to
  • upon clicking Test Class, a dialog with “The JDBC driver could not be loaded.” appears

I have used JDBC connections before under LO 3.x and MySQL before Mariadb came along. Ultimately, I want to use a connection to my database for further analysis of the data using Calc. Is this still possible? If my memory is not failing me, it is possible to open a Base registered database within LO Calc.


Please see this post → How do I set up a JDBC connector for MariaDB (or MySQL) in Base?.

And yes, you can access data in Calc from a registered Base file.

Thank you for the url. I am surprised I did not see it in searches carried out prior to posting here and on another site.

Seems I was doing everything right, just did not have the 1.5.x connector. Downgrading to that from the 2.3 connector was necessary

All is good!