Contar o número de ocorrências de um valor

Tenho uma lista com nomes de escolas e algumas se repetem.
Gostaria de uma formula que contasse quantas escolas tem. Ou seja, quantos Valores a coluna possui.

Usei a formula:

=CONT.SES(REGISTROS.C4:C53;"*")

O resultado foi quantas linhas de escolas há, mas elas se repetem então não foi o número de escolas. Tentei usar =frequencia mas não obtive o resultado também.

Você quer saber quantas Escolas diferentes existem ?

Pode ser assim também:

Com esta fórmula : =SOMARPRODUTO((B3:B18<>"")/CONT.SE(B3:B18;B3:B18&""))

Descrição da imagem

Consegui com essa fórmula. Agradeço!

Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

Só mais uma questão. Estou usando essa fórmula:

=SOMARPRODUTO((REGISTROS.C4:C53<>"")/CONT.SE(REGISTROS.C4:C53;REGISTROS.C4:C53&""))

Porém, gostaria também que ela só somasse as que estivessem com “Pública” em outra coluna.
Tentei inserir essa fórmula nela, mas não obtive sucesso de nenhuma forma.

; REGISTROS.D4:D53;"Pública"

Como é texto não é SOMAR é CONTAR

=CONT.SE(D4:D53;“Pública”)

A formula que funcionou foi a SOMAR que você mesmo disponibilizou.

A questão é que é a mesma fórmula porém que resultasse apenas nas que estivessem como PÚBLICA em

REGISTROS.D4:D53

@Dambia

Segue ARQUIVO

Fonte:

@Conras, obrigado pela dica, exclui a resposta errada.

baixei o arquivo, mas infelizmente não consegui com nenhuma dessas 3. Já havia inclusive olhado essa matéria do Office.
De qualquer forma, agradeço!