Contextual groups will not allow a font drop down menu arrow

I am using ubuntu 21.10. When I select contextual groups, there is not enough space in the group area for a drop down menu in fonts. There is a drop down in sizes, but not is fonts. The box for the font names is cut off on the right. I am using LO 7.2.4 version.

Please, edit your question to mention your LO version.
How do you get to “contextual groups”? Do you mean you have change the user interface?

First steps

Start there at: Graphics-related issues ( Skia )

I went into tools/options/advanced and selected “enable experimental features”. After that, one can navigate to view/user interface and select the contextual group. Works fine in windows.

Please, for community benefit, make your comment a solution and flag it as solving your problem.

visited that info, but not sure I understand. Will investigate further.

problem is not solved as it pertains to ubuntu, not windows.

I’m at work right now (Windows).
Either /opt/libreofficeX.Y/program/soffice
or /usr/lib/libreoffice/program/soffice
It is an editable text file (editable by root)

sudo nano /usr/lib/libreoffice/program/soffice

opens the script with the most simple editor nano (see bottom line for the Ctrl commands to save and close)


somewhere at the beginning below the comment lines.

I will have to do some digging to figure out how to edit the file. But you had the solution. Thanks.

Dropping gtk for LO solves many UI problems and instabilities including this one.
Start LO like this:

SAL_USE_VCLPLUGIN=gen /opt/libreoffice7.2/program/soffice

If this works for you, you may add SAL_USE_VCLPLUGIN=gen to the soffice start script.

Screenshot with generic VCL. With Gtk the drop-down button is missing.

is that a terminal command?

yes, it’s a terminal command to start the executable script /opt/libreoffice7.2/program/soffice with a temporaily modified environment variable which turns off gtk. If you always want to start LO like this (I do), add the variable declaration to the script.

I’m sorry I don’t understand. I copied and pasted what you gave me in the terminal and get the message that there is no such file or directory.

I can’t know where your soffice executable is. May be /usr/lib/libreoffice/program/soffice

which libreoffice 

and see what it reports


SAL_USE_VCLPLUGIN=gen /snap/bin/libreoffice

same message - no such file or directory. You know, this is not that critical. I will just use a different user interface. I think it’s odd that they get it to work in Windows but not in linux.

The font listbox with the hidden arrow is usable with Alt+Down Arrow

I know nothing about libreoffice in a sand box (snap)

I uninstalled libreoffice and reinstalled from a different package manager. my address became /usr/bin/libreoffice. I ran your command and it worked. However, the screen has a different resolution and all menus, fonts, etc are small. But the contextual groups worked.

Where do I find the soffice start script?