--convert-to does not convert data from DDE links

I am trying to convert automatically to PDF an odt document which contains some DDE links (cells from an ods sheet).
The output document shows empty tables in place of the ones linked. Of course, if I open the odt directly in writer they shows correctly, and if I click on “export to PDF” it works. Maybe the problem is related to the update of the DDE links, but I have not been able to find out a solution.

Is it a known issue, an unknown bug or am I missing something?

Thank you very much,

[LibreOffice 10m0(Build:2) on Linux Ubuntu 16.04 LTS]

can you give a little more step-by-step detail of the method you are using to ‘convert automatically to PDF’?

yes: I simply issue the command

libreoffice --convert-to pdf myfile.odt

I have also tried the headless* mode:

libreoffice --convert-to pdf myfile.odt --headless

but still doesn’t work

  • the doubt was that, being some links to be updated, libreoffice would wait for user input to accept the usual “update links” question, that appears when libreoffice (with GUI) opens a file containing link(s). AFAIK, “headless” suppresses the GUI so LO would not wait for any user input, but it seems I’m wrong

Looks like a similar question went unanswered on this forum. Are the DDE links in the document absoloute paths? I do not replicate with a =DDE() function in a spreadsheet, works fine for me with conversion. Haven’t quite figured out yet how to replicate in Writer.