--convert-to pdf Windows


I am trying to use the --headless conversion on windows 10 using Libreoffice 4.4. Here is one of the different combination I have tried

C:\Program Files (x86)\LibreOffice 4\program>soffice.exe --headless -convert-to pdf:writer_pdf_Export --outdir “C:\Home\install” “z:\Desktop\ALP.docx”

The command returns with no error message and no pdf file is produced. It seems like there is a missing dependency that is not documented. I do have Java installed.

I searched all the forums and documentation but didn’t find my answer.

Thank you if anybody can help me on this.

Try soffice.exe "z:\Desktop\ALP.docx", which should open the document in the GUI. Does this work? Can you export it to PDF via the GUI? If one of these steps fails (possibly producing an error message) that will help you narrow down the issue.

I have the same problem
if i run the command from limited user in windows 7
“C:\Program Files (x86)\LibreOffice 4\program\soffice.exe” --headless -convert-to pdf:writer_pdf_Export --outdir C:\PDF C:\PDF\53620_STAMPAD.RTF

nothing happens

but il i run command as administrator work

I have trying to convert xlsx to pdf, and from GUI i can export it. even then command by passing the input file, open the libreoffice GUI with the input file option to open … but it didn’t convert it to PDF

The convert switch is --convert to (note the two dashes).

--headless is not needed, as it is implied when using --convert to.