Copy and Paste images does not place image into document

Paste into a document results in an open window with the picture icon and “image1” in upper left most corner

Never use the Copy/Paste method for the images what you get from a foreign source.

Always optimize the images before you insert them into your document.

(Adjust the resolution [DPI], color depth, physical size and the file type with a third party image editor/manager software.)

Then insert the image into your document by the regular way (from the menu): Insert - Image

@Zizi64 wrote:

Never use the Copy/Paste method for the images what you get from a foreign source.


Is never not a bit too absolute? It always depends of circumstances and personal experience and the use of a document in future (sketch? print out? documentation? quick and dirty response? …). - Cheers

“Is never not a bit too absolute?”

In my opinion: is not. If you not know anything about the DPI, the color depth, the physical size, and the type of the image, then the Copy/Paste can cause many of mistakes. Huge file size, high memory consupting, slowened open procedure, program crash, etc…

The older version did not require all of these pre-paste steps. I am not a computer genius but these steps are frustrating, time consuming. Never had to optimize pic before and makes OfficeDepot harder to use.

“The older version did not require all of these pre-paste steps.”

All of versions and all of text editor softwares require these steps. Yes, you can insert the pictures without these steps, but the result never will be optimal.

You used the tag Common which refers to all the LibreOffice applications. Assuming you are using Writer, go to the menu option View and ensure Images and Charts is selected.

If this answer helped you, please accept it by clicking the check mark to the left and, karma permitting, upvote it. That will help other people with the same question.

In case you need clarification, edit your question (don’t use an answer) or comment the relevant answer.