Copy/Paste clipboard issues LibreOffice Calc

https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1852183

I have this problem as well (OpenSUSE Tumbleweed):

Version: 6.3.3.2.0+ Build ID: 30(Build:2) CPU threads: 6; OS: Linux 4.16; UI render: default; VCL: gtk3;

Calc wants to paste as an image if copied using the icon on the toolbar or right click. edit - maybe 50% of the time.

Works okay if use Ctrl-C to copy.

Very frustrating as I am mouse oriented and use spreadsheets all day.

I have created Bug 129319 in Bugzilla. Lets hope to get a resolution.

I am confirming that this is an issue on many platforms, not just Ubuntu. In the last couple of months, I’ve installed Ubuntu, Fedora, PopOS, Elementary - all the latest versions and I have the same copy/paste issue described by OP with every platform. This is definitely a LibreOffice issue. It is very annoying as I use LibreOffice exclusively and copy/paste is a basic function that you’d expect to just work.

This has now infected the hard key combinations. CTRL-X and CTRL-C.

Version: 6.3.3.2.0+
Build ID: 30(Build:2)
CPU threads: 6; OS: Linux 5.3; UI render: default; VCL: gtk3;
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

all the latest versions and I have the same copy/paste issue described by OP with every platform. This is definitely a LibreOffice issue.

Likely a wrong conclusion. All these latest versions probably have one thing in common: they use a recent version of Mutter as compositor, with its new clipboard “manager”.

I have a similar problem in LO Writer. Both right-mouse cut/paste and CTRL+X/V recently began acting up. It cuts, but then it pastes something old. It works as it should some times, normally if I try again and again.

Never seen it before, and it only happens in LibreOffice, not in say Firefox.

LibreOffice 6.3.3.2 in vanilla Ubuntu 19.10. I have no idea what a compositor or Mutter is.

It does not happen only in LibreOffice but also a few other applications, maybe not Firefox. Some are mentioned in the corresponding bugs somewhere:

See also Wikipedia’s Mutter and Compositing window manager articles.

I have this exact problem. Running Libreoffice_calc 5.2 on a Pixelbook. Using Crostini which currently runs Debian stretch. I am trying to migrate from MS Office 365 (excel) and this kind of elementary bug is a blocking factor. I did paste special and once got the expected menu where I could choose how the thing would be copied but most of the time I get a dialog box and when I do the paste it pastes in an “image”.

I am seeing this on Windows 10 64-bit, with LO 6.3.
Once the paste fails, I can switch to Word or Wordpad (ugh), paste there, select it there, switch back to writer, and then the paste seems to work.

Has anybody created a but in libreoffice for this yet?

So to summarize as answer not hidden in the comments, this appears to be a bug in the Mutter compositor’s integrated clipboard manager, which is used in Ubuntu 19.04 and other distributions. See

Update 2020-03-16T12:30+01:00:

Citing from the mutter bug:

I can confirm the problem disappears in LibreOffice when I disable
the Gnome Clipboard Indicator extension, and reappears when I re-enable
the extension.

So disabling the Gnome Clipboard Indicator extension might help some.

FYI, I’ll check Mutter, but the problem only occurs with Libreoffice apps,.

Check the launchpad and mutter bugs and you’ll see it’s not only LibreOffice.

I do not have that extension and still I have the problem on LO… what I’ve been doing is to press Ctrl+C twice every time. The thing is that LO often pastes the previous selection. This problem also happens on other apps, but is much more frequent on LO.

I have the same problem in both 19.10 and 20.04 releases. for me too the only workaround is to do the copy action twice. If i need to “cut”… well, i don’t. Copy + Copy then paste, then delete the part i needed to cut.

I have also this problems under Windows 10 and now also at LibO version 7.0.4. I have also to use a external clipboard-manager.

I had the same issue. Mutter has problems with Xorg. But it works like a charm with Wayland. So if you have copy/paste issue with Libreoffice, you can log in to your ubuntu in Wayland.

Indeed, that’s apparently why I don’t encounter it (on Fedora F31) because I use a Wayland session.

I tried turning off clipboard managers, and nothing changed. However… When I use keybd commands (CTRL-INSERT) to copy, the paste operation works every time. Same results with Calc, and Writer.

Hi
I have install wl-clipboard (available on Muon pack installer) and the problem is solved for me