Copy & Paste not working

Hi,
I’m using LO 6.2.0.3 on Antergos Linux with KDE Plasma Version: 5.15.0, Kernel Version: 4.20.7-arch1-1-ARCH, OS Type: 64-bit, no real changes made after ordinary installation (only changed the theme in LO from breeze to breeze dark). Copy and Paste is working between all other programs flawlessly and also inside LO, but it is not possible to copy anything into LO or out there. The first time I used Lo I cloud paste something into LO but not out again, but pasting in also stopped working. Really annoying! I tried as said here in the forum an on other places in the internet, delete user directory, restart in safe mode delete everything and also restarted the system afterwards, several times. Still not working!

Thanks in advance!

edit: c&p from Impress into a program outside the LO-universe is possible, but not the other way round

Same bug, Windows 10 using LibreOffice Base. I found the problem seems to be with accented characters. If I replace the accents with plain characters, it pastes fine. Then I add the accents in afterwards.

Same for me
Windows 10 64bit latest build
LibreOffice 7.1.0.3

Can’t copy and paste as any that symbols like “: , -, #, etc”
As long as it’s just text and numbers you can’t copy and paste any else.

Hello

this is a known bug please see LO Bugzilla.
The problem seems to be in the package libobasis6.2-kde-integration-6.2.0.3-3.x86_64 (if you use the packages delivered by libreoffice.org). You may get around this by deinstalling this package but you’d to deal with GNOME-like dialogs (file picker etc.)

Hello

thank you for your quick answer Opaque. There is one problem I have. I can’t find the package you mentioned and after de-installation of all LO components and a new installation of libreoffice-fresh-6.2.0-3 there was a “kio: for KF5 KDE desktop integration” in the installation dialog and the problem still occurred. Couldn’t figure out how to skip this. So I installed the libreoffice-still package (seems to come without the integration). There c&p is working. Thanks again for the hint :slight_smile: If anyone has already an idea how to skip the “KDE desktop integration” in Antergos/Arch (I simply used “sudo pacman -S libreoffice-fresh”) let me know. But not so important in bugzilla they say: “KDE5: Fix selection clipboard: It will be available in 6.2.1.”

Please notice what I wrote in parenthesis “(if you use the packages delivered by libreoffice.org)”. This was very intentionally since there are hundredth of distrubutions of Linux out there and from your comment I take the guess, that you are using pacman’s version of LibreOffice. I cannot comment on pacman’s libreoffice, since I never used this.

I have exactly the same problem on the same OS. I already filed a bug.
Any advances?

It happened when Writer 6.1.5.2 (x64) under Windows 10 Pro 1809 was open for longer than a day and memory use was above 50 %, as indicated by Task Manager. After restarting Writer the problem disappeared. It seems to be a memory management issue probably in relation to OS and not exclusively of Writer.

This problem also occurs in Apache Open Office Writer. Similar thing, after writer is open for some time, suddenly stops pasting. The previous clipboard entry stays in memory. I have tried a fix mentioned elsewhere, a little programme called Clear My Clipboard, but this does not cure it in either LO or OO. My OS is Windows 7 Pro. I hope this bug is fixed I otherwise enjoy LO/OO and I don’t want to go back to M$ Office!

Please post answers on this Q&A site only, if you actually do answer a question - otherwise please use add a comment. Thanks in advance.

I am on version 6.3.2.2 running on Windows 7 and am having the same erratic problem so I’m guessing that this bug was not fixed for this release - even though the bug report says that it was fixed in 6.2.0.2: https://bugs.documentfoundation.org/show_bug.cgi?id=122689

The bug you mention has nothing to do with Windows 7. It specifically handles kde5/qt5 vcl backends on Linux.

june 2020, i have half the same problem and think to know were it comes from.
the copy/paste routine does work for me aslong as LO is open…
as soon as i close LO the PASTE is EMPTY… yet while pasting 30 seconds before, to mouspad, it did work normaly.
But with a second PASTE command nothing happend even while the PASTE button in the menu was active.

OL probably try’s to limmit effort by creating a LINK to the copied part instead of realy copying the selected txt.
The solution to this problem is that OL HAS TO FOR FILL THAT COPY COMMAND!!!
its a not completed command yet the USER thinks to have done a complete command.
So when OL COSES the FINAL copy still has to be DONE cq forfilled and all will be working normaly.

and your ‘i am not a robot’ picture ARE TO SMALLLL

Windows 10.
Same bug.

Not gonna lie. Copy & paste is quite essential. This is a ridiculous bug and it’s even more ridiculous
that nobody fixed it yet.

The only thing ridiculous is this answer …

Lé Epic sick burn. 420 bruh moment. Apply water on the burned area of the derailed argument. xP
#bruh

2022 most popular os still broken ;-;