Copy/paste unreliable, Version:; Build ID: 1:6.3.3-0ubuntu0.19.10.1


Copy/paste is very unreliable WHEN COPYING FROM COMMENTS INTO THE TEXT. It often produces the previous clipboard content. I.e. you cut A, paste A, cut B, paste A (rather than B). If you undo, cut B again, then paste B. THE NORMAL COPY/PASTE (text to text) works. (Edits added in caps)

This is on Version:, Build ID: 1:6.3.3-0ubuntu0.19.10.1. (Gnome)

It seems to happen whether you use keyboard shortcuts or right-click menu.

I’ve seen some similar posts about clipboard problems, but they seemed to be to do with Windows, whereas this is on Ubuntu.

Any ideas what’s wrong here?

Many thanks!

AFAIK - LibreOffice doesn’t have its own clipboard management but uses operating system’s clipboard. Thus the proper way is to check the operating system’s (desktop managers) clipboard tool and its settings. And since Ubuntu offers more than one desktop manager (KDE, GNOME, Xfce, Mate, …) nothing to add, since you did not mention yours.

Hello, thank you for the comments. I have added the desktop manager, Gnome. I had also left out a major part of the description, in that this occurs when copying from comments into the text, rather than within the text - the latter would be immediately noticable by many users, but I suspect copying from comments into the text is less usual.

So I just tried, as I am on Ubuntu-MATE 19.10 and LO, and it worked nicely (just the size of the font was different when pasted on main text), I tried on a 20 pages doc with something like 2-3 comments per pages and it worked without any problems which either i cut and past or copy and past comments to main text and vice versa, so it might be your Gnome Desktop Manager.

Thanks for bringing this up. I am using macOS Catalina and am experiencing exactly the same thing. If I copy pictures from the web to the or clipboard(screenshot) to writer it keeps the same picture in “clipboard memory” for writer, but if I open Notes and do either crtl+V or right-click past it pasts the second picture that was copied. Then when I go to Writer and do ctrl+V it copies the second picture fine. This might be an operating system glitch as it only started to happen after I upgraded OS and LO. This also occurred while using Google Docs. A solution would be nice or pointer where to tweak preferences.

Thanks - good to know that this affects others too!