Corrupt Dbase form hangs LibreOffice when opened

I am running a 64 bit Windows desktop PC

I have used OpenOffice for a long time, but never used the database functionality. I recently changed to LibreOffice 7, and have been trying to create a simple database. On my first try LibreOffice told be I had to have the Java JRE running, so I downloaded it and installed it.

So, I have created two tables and two forms. Both went OK on first use, but I have been editing the first form to add new fields. At some point, working on this form started to completely hang LibreOffice (anything that was open did not respond, and had to be recovered when restarting LibreOffice). This happened mostly when editing the form, a couple times as soon as I copied a push button control with the right-click context menu. I finally managed to copy the control with a control-right click and drag maneuver, and finished editing the form.

Now, whenever I open this form for use, LibreOffice hangs and I have to use Task Manager to end the task. Looking at the details in Task Manager shows that what is not responding is always soffice.bin. I have tried LibreOffice safe mode and resetting the user profile, and even resetting everything to factory settings, but the problem persists.

I am assuming this form is somehow corrupt at this point, but do not want to have to completely redo all my work from scratch.

Any ideas?


Update - I opened this database in safe mode and opened the form. it worked ok, but then I also opened a write document from the open menu inside the open form, and LibreOffice hung at that point. I did a stop task and opened the database normally, then opened the form and everything was ok. I then opened the same Write document and everything was still OK. I was able to add data to all the fields in the form and add a new record to the table with a submit button, and then refresh the form with a refresh button. Everything is still OK??

I will continue to add records and if I run into no further problems, will close this forum question, but I still do not know what was causing the problem or what fixed it.