Corrupted ods file


I am using:
Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Locale: en-US (en.UTF-8)

I have worked an ods file since it was created on 14 April 2016. When I opened it yesterday, it opened and the spreadsheet had been replaced with a portrait document, like Word Document and not a spreadsheet that it was, and all the text has also been replaced with # (Hashtags). I restarted my computer and this problem was not fixed.

I really enjoyed using LibreOffice, though this has made me loose my work and I am looking at changing document program. I am writing this question here to hopefully help prevent this happening to someone in future as it may be a bug that can be fixed and also to see if it has happened to other people. If this file could be fixed then that would be a bonus. Other ods files are opening fine.

I’m troubling with a similar problem since about one week.

In my case, the .ods cannot be opened at all. Calc opens with the dialog for conversion of format. Obviously it’s not a matter of format to be converted. When it fails, even MS Office is unable to open it.

Fortunately, I had a backup copy of my files. Then I recovered the .ods from my backup copy, and I was able to work loading/saving for a few. But later it failed again.

I recovered from my backup again, and moved the .ods file to a different disk unit. It worked for a while, and then failed again.

My working folder is encrypted, on both the units I’ve tried, but it’s years that they’re encrypted and never had similar problems in the past.

Now I see that a Java update is available… I’ll try to update it.
I’m very worried for my lots of documents, and loosing a lot of time by querying from my backups, and I fear to save my changes.

LibreOffice Version:
Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Versione locale: it-IT (it_IT)

Usually this kind of issues happens when files are not properly saved, an issue typical using usb sticks for save the files, not being closed before get it out.