Could not create Java Implementation Loader on a Mac

Checked previous questions - don’t understand much of the explanations. Have downloaded and installed Java now, but still same result. Since then, I get “LibreOffice requires Oracle’s Java Development Kit (JDK) on MacOS 10.10 or greater to perform this task. Please install them and restart LibreOffice” I’d never that that window appear previously. That kit seem to require an Oracle account etc etc - I just want to add a Japanese dictionary to my Writer! I study Japanese, not computer programming etc. I have Mac OS Catalina 10.15.6.

Have downloaded and installed Java

And what exactly did you download and install? The error message says that you probably did not install the right thing. Get one from

I went to and downloaded and installed the suggested Java for Mac OS X, Version 8 Update 261released July 14 2020. The page you’re directing me to is one I subsequently found, but that seems to be a different thing to what the extension installation process requested in the first instance, but now just starting up LibreOffice wants that software whereas it did not previously request it. Furthermore, disregarding the prompt for the development kit doesn’t seem to stop me using Writer, but of course I still can’t install the dictionary extension. Do you think that I need both Java programs on my machine to achieve the result I want?

LibreOffice generally does not need Java except for a couple of legacy items such as the document converter wizard. Thus, you can use Writer. However, certain extensions do require Java (apparently, your dictionary extension does).

Try leaving the JDK that I referred to.

That kit seem to require an Oracle account

No - that’s incorrect.

From Oracle: Java SE - Downloads | Oracle Technology Network | Oracle (JDK14;JDK11; JDK8)

From AdoptOpenJDK:

From OpenJDK: JDK 14 Releases

>.. not computer programming etc

Nobody asks you to program anything. Just leave off these kind of remarks (which just proves you got no clue of what programming means) and tell us which LibreOffice version you are using.

> I went to and downloaded and installed the suggested Java for Mac OS X, Version 8 Update 261released July 14 2020.

That is not a JDK but a JRE, which won’t work on macos (see links above)

> wants that software whereas it did not previously request it

Probably you install the dictionary extension for the first time, and this seems to require Java.

To Gabix - thanks so much for your attempts to help me. I think I’ll just find another program that will allow the dictionary function as it doesn’t seem like it’s worth the trouble. I downloaded and installed LibreOffice only two days ago, so I guess it’s that latest version for my machine. I then searched for a dictionary extension and downloaded it but it wouldn’t install and I got the error message previously mentioned. Checking this forum for answers I came to understand that I would need to download Java (a JRE) , which I did, and that lead to further errors saying that I needed a JRK, which I downloaded and installed to no effect.

To Opaque - Please forgive my poor choice of words - I should have said ‘…not computer-related software installation problems.’ rather than “computer programming”. I make no pretense, nor have any desire, to know about computer programming. I just made a remark out of frustration that was not directed at any one person nor group; sadly I can’t say the same about your remarks about me. Maybe it is you who should just leave off such comments as it just shows that you have little respect for others who don’t meet your expected level of knowledge in your field of expertise. 分かりましたか?

By the way, you did not mention which extension you tried to use. I found this one:

It did not work for me in LO 6.3.6 under Windows 7.

However, the last version was released in 2009. The extension may simply be incompatible with the latest LibreOffice and/or JRE.


no capiso…

Opaque, stop this nonsense. While ipbirchley may be overreacting, his/her question is, in my opinion, better than 80% ones asked here. Thus, focus on the technical side.

Thanks very much Gabix, that extension is that one which I tried to install. Thanks so much for your time and assistance.:slight_smile: I’m sorry if you feel I over-react to some comments, I do my best with these things. I am of the age where I started school learning to write on a slate and I clearly remember the first time I ever saw an electronic device which could add numbers, so I do not take kindly to those (presumably born into the electronic age) who would say things on a computer screen that they would not say to my face. Anyway, thanks again - you’re appreciated.