Country redirect ... I don't like that!

This site all of a sudden redirects to the website’s version of my country’s language.
In this version I don’t see any questions/posts (because there aren’t any).

I don’t want that!!!

I Always want to see the English (default) version.

Please developers can you fix this. This is unwanted behaviour.



Thanks for your replies. I’ll just have to get used to typing the correct URL (with language) then.

I would however appreciate a “language selector” to easily skip to another language as user RGB-es suggested.

There is one thing the site can (must?) do and it is to add a “language toolbar” (like the one on the wiki) to help navigation between different languages.

I visit the English, Spanish and Italian site (almost) regularly and that means that I need to either use three different bookmarks for what it is essentially one site or edit the url each time I need to change from one language to the other.

Yes, I am redirected too.

Of course you can just bookmark

And in Firefox, you can set your preferred language for websites.

I suppose there’s nothing broken; possibly your language’s section was added to the site, and thus began to be correctly redirected to. There’s nothing to fix in the site configuration; if you prefer another language’s version, please follow @Gilward_Kukel’s advise and use either direct bookmark, or change browser preferences wrt preferred site’s language. The new localized section cannot be expected to contain any content from the start; and it’s incorrect to expect that all users prefer English to their native language, so your preference should be considered a special case.