crash recovery

I updated to version hoping that the recovery would operate well as before. It is still the same.
When I have to do a re-boot because Windows gets confused, I get a recovery window in Libre Office Calc. that asks if I wish to recover file or discard. I click on recover and it usually does that and says file recovered and then I click on finish.
For a few weeks now, it says “recovery failed”, but when I click on “Finish”, the file opens as usual with all of the data.

Hello, does it appear regardless of the file or on certain files only and have you already tried to reset your user profile? Any your operating system is Windows (which version) ?

No, I have not tried to reset my user profile. I didn’t know how or or if it was required.
Windows 8.1 quite often partially crashes. The icons in the tray won’t work and the time is wrong, and I have to use Ctrl, Alt, Del to re-boot.
I guess that I could use Task Manager to close the open Calc. sheet to prevent this problem when the re-boot is required.
Actually, as I clicked on “save comment” a couple of minutes ago, that crash happened again, so I used the task manager to end the programs. Same result with “recovery failed” even though I closed it first.