Crashing on startup every time

Upon opening any LibreOffice 6.3 application I get a box asking me if I want to recover “Untitled 1”. I can choose “START” or “DISCARD”. If I choose “START” the recovery fails and the program closes. If I choose “DISCARD” the program immediately closes.

My system:

System:  Kernel: 5.2.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           Desktop: KDE Plasma 5.16.4 Distro: Manjaro Linux 
Machine:   Type: Desktop System: LENOVO product: 90H1000FUS v: ideacentre 720-18ASU 
Mobo: LENOVO model: 3100 v: SDK0J40700 WIN 3258080906218 serial: <filter> UEFI: LENOVO 
           v: O38KT31A date: 08/24/2018 
CPU:       Topology: Quad Core model: AMD Ryzen 5 1400 bits: 64 type: MT MCP arch: Zen rev: 1 
           L2 cache: 2048 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 51122 
           Speed: 1366 MHz min/max: 1550/3200 MHz Core speeds (MHz): 1: 1444 2: 1672 3: 2806 4: 3053 
           5: 1374 6: 1372 7: 1375 8: 1373 
Graphics:  Device-1: AMD Oland [Radeon HD 8570 / R7 240/340 OEM] vendor: Bitland Information 
           driver: radeon v: kernel bus ID: 09:00.0 
           Display: x11 server: X.Org 1.20.5 driver: radeon FAILED: ati unloaded: modesetting 
           resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: AMD OLAND (DRM 2.50.0 5.2.8-1-MANJARO LLVM 8.0.1) v: 4.5 Mesa 19.1.5 
           direct render: Yes 
Audio:     Device-1: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000 Series] 
           vendor: Bitland Information driver: snd_hda_intel v: kernel bus ID: 09:00.1 
           Device-2: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 12:00.3 
           Sound Server: ALSA v: k5.2.8-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo 
           driver: r8168 v: 8.047.02-NAPI port: f000 bus ID: 01:00.0 
           IF: enp1s0 state: down mac: <filter> 
           Device-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo 
           driver: rtl8821ae v: kernel port: e000 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.82 TiB used: 220.30 GiB (11.8%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000DM003-1SB102 size: 931.51 GiB 
           ID-2: /dev/sdc type: USB vendor: Western Digital model: WD10 EARX-00N0YB0 size: 931.51 GiB 
Partition: ID-1: / size: 906.94 GiB used: 220.30 GiB (24.3%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 42.6 C mobo: N/A gpu: radeon temp: 58 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 281 Uptime: 1d 23h 23m Memory: 7.79 GiB used: 4.27 GiB (54.8%) Init: systemd 
           Compilers: gcc: 9.1.0 Shell: bash v: 5.0.9 inxi: 3.0.36

What I have tried:


Uninstalling LibreOffice and dependancies

Installing clean

The problem persists.

Manjaro forum fixed me up:

start libreoffice in safemode and reset all user preferences. then the next time it should run properly

you need to use the terminal command below to do this:

libreoffice --safe-mode

Thank you. My libreoffice kept crashing on startup. This command helped.

$ libreoffice --safe-mode

I reset to factory setting. Now everything (everything?) works!
Thanks, Manjaro

had the same problem, starting in safe mode and doing a reset of user preferences worked perfectly