Create a table of contents that only picks up one style

What I can never work out is how to do exactly what my title says. I have tried all sorts. I want a table of contents that only shows H1 and does not pick up H2 or H3 as well.

I do not want chapter numbers. JUST the names of the chapters.

Please can someone explain how to do this to my addled brain? I am sure it is all too simple when you know how. I read the instructions given and seem to end up with the same old thing of chapters and subheadings whatever I do. I then end up editing what I do not want out. In a long document, this is a tedious job.

(I would also like to make a TOC with a particular heading as a secondary table. -i.e. I have “Tasks” saved to a style I made and would like to make a list of these separately from the chapter headings.)

I would then have my chapters on a page and another page where all the tasks are listed and linked to.

I do not want subheadings.

Edited to say that the answer in the comments below works well and I was quickly able to format my TOC.

When you create the TOC (Insert → Table of Contents and Index → Table of Contents, Index or Bibliography), on the Type tab, under Create from, enable the option “Additional styles” and disable both, “Outline” and “Index marks:” now you can access the “Assign Styles” menu and select only those styles you want on your TOC: select the style from the list and use the buttons you find on the lower left corner to move those styles to the level you want.

To delete the chapter numbers, go now to the Entries tab, select, for each level you use on your TOC, the E# button (it represent the heading number) and press Del.

If you are interested on learning more, I go into more details on how to set up a TOC (among many other topics) in my free book about Writer :wink:

1 Like

Just wanted to know if using “Evaluate up to level: 1” doesn’t do the trick without changing the source from Outline to Additional styles?

@mikekaganski for the general TOC, yes, but for the “tasks” TOC, you need to use custom styles.

@RGB-es: thanks; just wanted to know if there’s a known problem about that not working for some reason.

Brilliant. This may have seemed obvious, but I have been trying to find a way for years. Thanks. I will look at the book.

Thank you.