Create external image link in Writer in MacOS

Continuing the discussion from External link to display image in writer?:

I’m trying to create an external link to an image in Writer by using a URL, as described in the above post from @Regina. However, I see no way to add the URL. I choose the menu items Insert>Image, click the Options button and check the Link option. However, I’m only able to select a file in this dialog, there is no place to enter a URL.

I’m using MacOS (10.13.6) and LibreOffice If someone here has a way to add a URL as a link to an image (i.e. meaning the image referenced will appear in the document) using LibreOffice and MacOS, please let me know how you do this. Thank you!

Try Insert>Hyperlink ( Ctrl+K ).

Thanks, but that only inserts the URL as a text URL, it doesn’t show the image the URL refers to within Writer.

This may depend on OS and desktop manager.

When you Insert>Image, a file dialog pops up. Usually, you use it to navigate in your file system to select a file. But on *NIX OSes (MacsOS is based on BSD), you can prefix a URI with a protocol to tell the kernel which IO module to use to retrieve the resource.

Here, you don’t navigate to a file. You manually type in the File: entry box or similar. You tell Writer this is not an ordinary filename by ticking the box Insert as Link.

Yes @ajlittoz, but as mentioned in my first post, there is no place to enter the URL.

You might be able to use the LibreOffice dialogue box by clicking in LibreOffice > Preferences > LibreOffice > General and tick the box Use LibreOffice dialogue boxes

Or you could use the alternative method Regina mentioned.

  1. Insert any image. Right-click it and select Properties.
  2. In the dialogue box that opens select the Image tab and under the heading Link enter the URL for your image, in this example a Public Domain image,
  3. Select the Crop tab and either press the Original Size button or enter the same percentage, e.g. 50%, for Width and Height under Scale and click OK

As you can see in the image above, the original image has been replaced by the URL linked image


In addition to @ajlittoz :

With me:
Windows 11, LO (x64)

Thank you @EarnestAl - this is the solution I was looking for. Both of your suggestions work, but the first of them (changing the preferences to use the LibreOffice Open/Save dialogs) is the simplest and most straightforward. The second suggestion, inserting a different image then changing its properties to include the link, works but it’s somewhat cumbersome compared to changing the Open/Save preference, especially when performing this for many images.

Many thanks again for the solution!

1 Like

Thanks @Hrbrgr, but this does not work using the native MacOS dialog since there is no place to enter the link, as I mentioned and showed in my earlier screenshot. The key to this, as @EarnestAl suggested, is to change the LibreOffice preferences to use the LibreOffice Open/Save dialog rather than the native MacOS dialog.