CSV file import problems

I use Ubuntu with LibreOffice (Version:; Build ID: 1:5.3.1-0ubuntu2).
I try to open csv file. Format:

Gręžinys;Mėginys;Nuo;Iki;63;31.5;16;8;4;2;1;0.5;0.25;0.125;0.063;0.01;<0.01;Svoris;Filtr. Koef.

Here are link to csv file, import window and calc images

After double clicking on csv file opens Text import window. In here all data looks fine. I press OK button and LibbreOffice Calc window opens, but here are two problems in first row. Number 0.125 becomes number 125, and number 0.063 becomes number 63.
All other numbers are okay. How can I fix it?

Set US English as the column type.

However, I see no such problem even with the Standard type.

May happen in this case if the standard locale uses a ‘.’ dot as group separator, not as decimal separator.

On the text import dialog, tick Detect Special Numbers. That seemed to work for me when I imported your csv file.

Some of the entries under Græþinys have an underscore in them; they import as text.

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

It should be Gręžinys, the text encoding being ISO Latin-13.

Detect Special Numbers did not worked for me, but setting column type to US English worked.