CTRL+F Doesn't Toggle Find Toolbar

Running Antergos 19.4, using distro-supplied LibreOffice Version:

I should first mention that I accidentally re-assigned CTRL+F to another hotkey, and then tried to reassign it to the original function (find toolbar), but I can’t find the entry in the Customization menu. I have also tried to reset the hotkeys to default, but this did not work either.

Please advise! Dearly needed function D:


First, try Ctrl+Alt+F.

If resetting does not help, try a long way as follows:

  1. Export key shortcuts to a cfg file via the customize dialog (and make a backup copy).

  2. Extract \Configurations2\accelerator\current.xml.

  3. Open and find lines containing "KEY_F". There may be several ones depending on your setup, you need the one without accel:shift.

  4. Replace the line with this one:

    <accel:item accel:code=“KEY_F” xlink:href=“vnd.sun.star.findbar:FocusToFindbar” accel:mod1=“true” accel:mod2=“true”/>

or with

<accel:item accel:code="KEY_F" xlink:href="vnd.sun.star.findbar:FocusToFindbar" accel:mod1="true"/>
  1. Repack the xml file.
  2. Import the cfg file.

Hi gabix,

Thanks for the awesome walkthrough! I am currently in step 3; however, I only have one entry in my file, and it is as follows:

   <accel:item accel:code="KEY_F" xlink:href=".uno:RepeatSearch" accel:shift="true" accel:mod1="true"/>

Should Step 4 in your instructions be added as a new line underneath the one I included, or replaced?

Also, how should the .xml file be repacked? Have not done that one before.

Thanks again

Yes, try to add the line. Use any archiver available to replace the xml file in the archive with the new version. I simply copy files to an archive using Krusader.

Worked! Though the command is now Ctrl+Alt+F and not Ctrl+F – something I can adjust to.

Select Tools>Customize ... from the menu.
In the “Customize” dialog box, select the “Keyboard” tab.
On the right side of the dialog box, click on the Reset button.

I wish you success!