CTRL+M in LibreOffice Writer no longer works after updating to


Exactly as stated - CTRL+M in LibreOffice Writer is no longer the hotkey to clear formatting after updating to 6.4, it will not react even when set to it, nor will setting it to alternate keystrokes clear the problem.

EDIT: In using LO, I’ve discovered that CTRL+M does work, but not when text is selected. It allows me to clear formatting while typing, but not to clear formatting on highlighted text. I don’t know if this helps diagnosis.



Ubuntu 18.04.4 LTS

Steps Taken

I checked Tools > Customize > Keyboard. CTRL+M is blank. Remove Direct Character Formats is listed as CTRL+SHIFT+X, which I believe is the desired option (though I’m ready to be corrected on that).

I tested CTRL+SHIFT+X. No obvious response. No cleared format.

I set CTRL+M to be the hotkey for Remove Direct Character Formats and tested it. No obvious response. No cleared format.

Just in case, I tested CTRL+SHIFT+M, and it tried to close either the document or LibreOffice as a whole. The doc was unsaved, so I hit cancel. This wasn’t listed under CTRL+SHIFT+M in the Keyboard Customize window.

Searched here. My search-fu is not very strong, but I found what seems to be the exact issue here, including the CTRL+SHIFT+X issue. The solution listed there (renaming registrymodifications.xcu) was tried. File was renamed after closing LibreOffice. Reopened, but CTRL+M still did not work, nor did CTRL+SHIFT+X. CTRL+SHIFT+M still tried to close the window (I don’t think CTRL+SHIFT+M is relevant, but I mention it just in case). (After this, I closed LibreOffice again and restored the original registrymodifications.xcu file).

Gave up, posted this.

EDIT: Then I almost immediately realized an obvious step to take. I selected text, right clicked and clicked Clear Direct Formatting. The context menu worked, but the hotkey remains cold (I tested both CTRL+M and CTRL+SHIFT+X).

One attraction looking at questions is that one may find new (or long-forgotten) features, or may be able to help someone struggling with a problem one solved earlier.

This just happens to be the first question which seems within my - admittedly low - level of knowledge.

Using LO on Win10home v1909 - both updated within past 24 hours

For CTRL+M , LO help : “General Shortcut Keys in LibreOffice” states :
“Removes direct formatting from selected text or objects (as in Format - Clear Direct Formatting)”

What is does : removes the ‘bold’ attribute applied without a style (i.e. direct formatting) from any characters in that bit of text which had been selected before invoking the command.

What it does not : remove a Style applied to a previously selected portion of text.
This seems in line with what the Shortcut Keys Help Page promises?

Searching for the other two key combinations - CTRL+SHIFT+M and CTRL+SHIFT+X : these return ‘The text that you entered was not found’

That does in fact describe how it behaved prior to the update. CTRL+M removed direct formatting. I never used CTRL+SHIFT+M or CTRL+SHIFT+X, so I can’t tell you how they’re supposed to behave.

Do you have any insights as to how to get it to resume normal behavior?

Further information gained.

In using LO, I’ve discovered that CTRL+M does work, but not when text is selected. It allows me to clear formatting while typing, but not to clear formatting on highlighted text. I don’t know if this helps diagnosis. Editing the above post to include this.

This was bugging me too. It turns out the change is to the name of the function which is now called Clear in the Format group. Go to Tools/Customise/Keyboard then find Ctrl+M in the top panel, Format/Clear in the bottom panel then press the Modify button. That did it for me anyway!

On my Fedora 33 / Libre0ffice
“Clear Direct Formatting” remove the formatting set by hand but keep the character style
Ctrl-M properly trigger this action on my system.

The command Style / Default Character (i.e. context menu / Character / Default Character) remove the style and reverts it to its Default.
I was used to Ctrl-space to activate this command but this association no longer works because the name of the command changed: it was “Default Style” and is now “Default Character Style”.
I attached the shortcut Ctrl-space to the “Default Character Style” and recovered the previous behaviour.

The most common problem I know of is ignoring possible specifications by character styles.

Character Styles in Writer


But they won’t be able to figure it out remotely unless they can look inside your file.

Upload your anonymous and possibly shortened file here. For this edit your initial question.