Ctrl+Shift+Arrow does not work in Calc

Hello. I use this shortcut in open office but on calc it does not work well.
the cursor should stop at the last non-empty cell. Meanwhile, it goes down to the end of the sheet.


Usually occur when you type content in a cell and press Enter (or something similar). To avoid this behavior press the arrow once, then Ctrl+Shift+Arrow.

Not a bug; it help in other circumstances.

Can’t confirm your claim on:

Version:, Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kf5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US,Calc: threaded

@anon73440385, I’ll try to repeat (don’t remember exactly how). It’s consistent (at least in LibreOffice_6.2.8.2_Win_x86). Now I am with
Select a range with more than one row. Modify something (delete, change font color, etc.), then Ctrl+Shift+Arrow. I think there is more examples.

For reference, I had ctrl+shift+otherkey require ctrl then shift then other key on the left side only of my keyboard under Ubuntu 20.04 with updated kernel 5.16.9. After a complete reinstall (for other reasons) using same version and kernel (same install media), normal, order-indifferent functionality returned.

Go to: Options → LibreOffice Calc → General and check “Position cell reference with selection”.

This used to be checked by default a long time ago. Now the default behavior is strange, ctrl-arrows stops at the last non-empty cell by default, don’t know why this is not the case with ctrl-shift-arrows.