Custom keyboard shortcut not working

Hi there

I am using Version on mac osx 10.8.3.

I have been trying to assign a keyboard shortcut for insert hyperlink in Writer. The keys I wanted were shift+ctrl+H. I have saved that combination for writer and for LibreOffice as a whole but when I enter the keys nothing happens at all - no dialogue box opens or anything. Nothing else happens within my computer which makes me believe that shortcut is not saved for any other OSX function, and I have checked it against this document:

I also tried a few others like cmd+. and cmd+6, but in each case using the shortcut has no effect, despite it being saved in the customize menu.

Am I doing something wrong or is it actually impossible to make shortcut for this command?



Thanks owen g. You were right, in as much as I was using hyperlink, not insert hyperlink, but having now switched to insert hyperlink, it has made no difference. I still experience the same issue.

This is a contentious matter. There are a pair of old bugs AOO#56160 / FDO#50063 relating to this. It is really a terminology issue though. The problem is the name of the required Category and Function pair:

  • Edit > Hyperlink = insert a new hyperlink (via Hyperlink dialog).
  • Insert > Hyperlink = edit a highlighted hyperlink (via Hyperlink dialog).
  • Insert > Insert Hyperlink = insert a new hyperlink (via Character dialog).

You are probably using the first second one, when what you require is the second last entry. The first and second entries are conflated in terms of naming vs action.

EDIT: To clarify what I am doing here (with respect to the second and third options) I am including screenshots of the Customize dialog for Ubuntu, Win7HP, and MacOS 10.6.8. Assignment of CNTL+SHIFT+G (Ubuntu/Win7) / ⇧⌘G (MacOS 10.6.8) to “Insert > Hyperlink” and CNTL+SHIFT+H (Ubuntu/Win7) / ⇧⌘H (MacOS 10.6.8) to “Insert > Insert Hyperlink” works exactly as expected (excepting naming/action differences) on all systems. That is, Insert > Insert Hyperlink allows insertion at the point of the cursor, while highlighting an existing hyperlink and using the Insert > Hyperlink shortcut allows editing of that hyperlink. All screenshots and tests performed with LO v4.0.2.2.

It is possible that MacOS 10.8.3 and / or WinXPSP3 experience different behaviour, but that would be a platform-specific issue.

Thanks owen g. You were right, in as much as I was using hyperlink, not insert hyperlink, but having now switched to insert hyperlink, it has made no difference. I still experience the same issue.

That is odd. Did you have a read through the bugs? There may be some help there. Otherwise I am out of ideas. You may have found a platform-specific bug, in which case it may be worthwhile commenting in the FDO one about your situation.

Hi OwenG. I think I have understood things a little better, and it’s slightly weird. I can now get the insert hyperlink to work, but not exactly with the keyboard shortcut I expected. On the customize menu I currently have the insert hyperlink shortcut set to shift-ctrl-H. Symbols are: ⇧ (up arrow), ^ (up arrow without stem), H.

But to get it to actually work I have to press shift+cmd+H.
I haven’t tested to see if other shortcuts will have this error. Am I doing something wrong?

Try setting it to the key combo I mention above. It certainly works here, as indicated.

thanks oweng. this does resolve the issue for me. i still find it confusing that the previous setup I had made in the customize dialog box, shift+ctrl+H, required me to press shoft+cmd+H to get it to work. I suppose the customize menu is a buggy part of the programme at present, and should I create any other shortcuts I should expect to have to play with them a little to get them to work. I am relatively new to Libreoffice and am enjoying using it generally. SD

Yeah, I am not sure why your particular combination behaved as it did, but I am glad you got it working.

I think that I now found the “insert hyperlink” functioin in the category “insert”.

I assigned also “insert” & “insert hyperlink”.

Wihen I use ctrl+shift+K (“insert”&“hyperlink”) there is no reaction at all

Wehen I use ctrl+shift+M “insert” & “insert hyperlink”) the following window opens

image description

when I use ctrl+shift+L (“edit”&“hyperlink”) I get:

this is for LibO and

I hope I am now on the same track.

That is right in your example about CNTL+SHIFT+K (Insert > Hyperlink). It only works if you first highlight an existing hyperlink. Your CNTL+SHIFT+L (Edit > Hyperlink) works regardless, thus as it says in fdo#50063 the action of these two functions appears to be transposed. I can see now that I have not made this as clear as I could, so will edit my answer. The Insert > Insert Hyperlink function works as expected. Sorry for the confusion.

@oweng - I think you not create confusion. There is IMHO a bit confusion in Writer and I hope this discussion contributed to clarification and additional information to fdo#50063 . In turn I hope our devs will have soon some time to improve this.

@Savedate - I think you did not do anything wrong. @oweng’s bugs listening (thanks for that) made me looking into this because I am a fan of short cut keys.

When assigning a the short cut “insert” & “hyperlink” and “edit” & “hyperlink” the asssinged text in the shortcut window says in both cases only “hyperlink”

When using the shortcut key for “insert hyperlink” nothing happens, when using the shortcut key for “edit hyperlink” the Hyperlink windows opens and I can insert or edit a hyperliink.

I tested with
Version (Build ID: f969faf)
Version (Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)
XP Pro / SP3

and added a comment

It would be good if you report your findings as well.

Can you please confirm that the shortcut shown is “Hyperlink” rather than “Insert Hyperlink” as per my screenshots above? I set both for clarity. Thanks. EDIT: I have just realised (from reading fdo#50063) you are using the “Edit > Hyperlink” shortcut. Re-read my answer above. You will see that to edit a hyperlink the shortcut is “Insert > Hyperlink”.

@oweng - Please have a look at the screen shots.

Insert Hyperlink

Edit Hyperlink

Ros, I think you need to use a different option for insert hyperlink. It should be Insert>Insert Hyperlink, not Insert>Hyperlink

@ROSt53, yeah I know both those options will produce an entry titled “Hyperlink” in the shortcuts list, but this is because both use a Function with the same name. My point in my answer was that a differently named Function (as @SAVEDAVE indicates) is required.