Customized items in Toolbar (Writer) does not show up

Hi there,

I’m using LO on Fedora 34. When I use the Customize function to add Left-to-Right / Right-to-Left to the toolbar it works all fine in the Customize menu but when I return to the Writer the new items are not shown. I can add any other command the outcome is the same.
As if the changes are not “persisted”.

I tried to test and add them to a menu(e.g. Edit). They show up but disabled and grayed out.

Have been using LO Writer for many years & this is the first time I can’t customize the Toolbar.
This is not because of SELinux because even if I set Enforcing to Permissive the problem remains unchanged.

Any idea?

You can save such changes in a document or for the user interface. If you save them in the document, they will only show up when you open that document.

What is the Target toolbar that you are choosing? It is visible (see menu View - Toolbars).

When I tried to customize I had a document opened. There’s no “scope” concept in this operation to tell between “global” vs “document” scope. Anyway the new items were not shown.
My favioured target was “Standard”. But I tried it with different targets to no result.

I found out the solution. I had to go first to: Options>Language and activate the “Complex Text Layout” and select a language with Right-to-Left layout. This way the toolbar change automatically and gets the new right icons.