Customized shortcut keys not working

I have tried to create customized shortcut keys on numerous occasions but nothing works. For example, in the Tools menu, I go to Customize. Under the Category, I choose Table. Under Function, I choose Insert Rows. Then I choose the shortcut key above and click Modify. Nothing. It doesn’t work. I’ve tried it with the Writer button clicked on the right side- nothing. I’ve tried it with the LibreOffice button clicked on the right side - nothing. I am on a Macbook OS X 10.8. I am using LibreOffice English License Version 3.

Please help. Thank you.

It seems that there is a bug. I made a test on XP using L+ibo
Key assignments:
alt+ctrl+down = delete column
alt+ctrl+ up = insert column
these two are working
alt+ctrl+left = delete row
alt+ctrl+ right = insert row
these two don’t work
alt+ctrl+left makes the left border of the column moving the right.

@wgwg - May I ask you to please file a bug report here:
and publish the bug report number here to allow others to add comments?