Cyrillic characters being typed are converted to gibberish

Hi everyone,

Whenever i try to type anything using Cyrillic layout in LibreOffice, the characters are being replaced with the likes of


This problem only occurs in LibreOffice suite. Moreover, pasted characters are not being converted, for example I can type anything in any other application, e.g. Chromium bar and paste it into Writer and it’s not being changed, but trying to type the same thing in Writer produces result similar to the one shown above. I have tried several fonts with declared Cyrillic support to no avail.

Thanks in advance.

Edit: Arch Linux 4.12.8-2, Plasma 5.10.5, LibreOffice 5.3.5-1, default RU layout on a generic 101-key keyboard.

Hello @Seiren,

Did you select Russian as an input source in your Text Entry settings?

i also set the “Locale Setting” to “Russian” in the menu "Tools : Options : Language Settings : Languages", and i also set the “Default Languages for Documents (Western)” to “Russian”.

then it works OK on my Ubuntu 17.04, LO Version:

‘Text Entry’ settings are an Ubuntu thing. On my system I have the ru_RU.UTF-8 locale installed and the default RU layout selected for keyboard. As I mentioned, everything works well considering alternative language input, so I strongly believe this to be a LO issue.

Otherwise, I tried changing LO settings as you suggested, but it didn’t fix the problem.