Dashes with grey background when copying text

Text on http://www.wetek.de/ueber-uns/leitbild.html looks like this:

Copied into LibreOffice Writer, i looks like this:

It doesn’t matter whether I use Ctrl+C/Ctrl+V or select and middle mouse button (in Linux).

How do I get rid of the dashes and there grey backgrounds?

Optional: Why are there dashes and grey backgrounds?

Build ID: Arch Linux build-3
Locale: en_US.UTF-8

These are soft hyphens, used for hyphenation. They indicate where words can be hyphenated if they don’t fit into the line completely. They will not be visible if the document is printed or exported to PDF.

To hide them, choose Tools > Options > LibreOffice Writer > Formatting Aids, and then clear the Custom hyphens check box.