Data/XML Source button disabled


I am trying to import an XML file through Data/XML Source but it is disabled, even if I start a new document. I was wondering why? I am using Ubuntu 16.04.

Build ID: 1:5.4.0~rc3-0ubuntu0.16.04.1~lo1
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2;


Did you have a change to report the bug?!
Same for me here on Arch Linux

The bug has been reported at as noted by @PYS in this answer.

Confirmed with:
Version: (x64)
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 4; OS: Windows 6.19; UI render: GL;
Locale: es-ES (es_ES); Calc: group

Please can you report the bug,, looks like a regression from 5.3

I have the same issue.

Build ID: 1:5.4.0~rc3-0ubuntu0.14.04.1~lo2
CPU threads: 8; OS: Linux 3.16; UI render: default; VCL: gtk2;
Locale: en-US (en_US.UTF-8); Calc: group

According to the discussion of the bug report (linked in a comment to the question), this feature is experimental-only. In other words, you need to activate it from Tools → Options → LibreOffice → Advanced → Optional Features → Enable experimental features (may be unstable).

I’ve tried it and my XML Source got enabled.

Does not work in According to the bug report, this requires or 5.4.5.