Database won't recognize my jre - can't create database

Hi there,
I’ve been wracking my brain trying to figure out how/why LO base won’t recognize my JRE installation. I’ve restarted my computer; I’ve reinstalled the latest jre (8); I’ve even reinstalled LO ( still nothing will break the chains of this program telling me that no java runtime environment is installed. This is very frustrating. Any and all help is greatly appreciated.

You fail to state what OS you are using. This is important.

If LibreOffice is 32-bit then you need 32-bit JRE.

If LibreOffice is 64-bit then you need 64-bit JRE.

If on Mac OSX then you need JDK not JRE.

Make sure of your settings. From menu Tools->Options (LibreOffice->Preferences for MAC). Check Java runtime environment box & select JRE (if no JRE, wrong one is installed) :

image description

If this answers your question please click on the :heavy_check_mark: (upper left area of answer).

I’m sorry for the omission. I am running Windows 8.1 64bit OS. I installed the only JRE available, it did not specify 64 or 32 bit operation. I looked in Options>Tools>Java and nothing appears there. I will go back to Oracle and see if I can download some other version.

I did, through research find someone saying something about using 32 bit JRE on a 64 bit machine. I don’t know what that is all about.

Thanks for you help. I will let you know how it goes.

I did download the 64 bit jre the first time. That’s what I installed. But it is not working. I have now downloaded the 86 version and will try that out.

@rocknriter FWI - the machine/OS bit size has nothing to do with the JRE for LO. It is the bit size of LO which was installed that matters. IE: 32-bit LO can be installed on 64 OR 32 bit OS which then requires 32-bit JRE.

So I tried the x86 version (32bit) and it worked. I don’t understand why, but, it did and I am very happy.