Date formatted mm/dd/yyyy, fields shows yyyy/mm/dd

I am using Version: (x64) Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
In Base I have field in a table with a date that is formatted as mm/dd/yyyy. I have one form that uses a Query to give me an age from the DOB. When I open the query, the date is displayed mm/dd/yyyy. The form with the query has the date displayed correctly as mm/dd/yyyy. For 3 other forms that use the same table as the query, the date field is also formatted as mm/dd/yyyy, yet the field shows the formats the date as yyyy/mm/dd. I have tried to leave formatting for that field as text and if I change it to date format of mm/dd/yyyy. I deleted the date, copied the DOB field that does display correctly. It displayed correctly until the following day. When opening the field, it displays again as yyyy/mm/dd.

Using Linux Mint with LO v6.0.2.1 I cannot duplicate. Please post a sample of your .odb without personal or confidential info.

I got it to work by using the Formatting box in the Control menu box , I deleted the formatting directly from the box instead of using the drop down list t o change the formatting. I had tried to take out the formatting before using the list and I crashed the program. I had to restart my computer to get it working right again.

I upgraded first to, then deleted the formatting. It now displays correctly

If I may comment as a user … In my own experience with LO and other office suites, date and time formats are a continuing source of trouble and annoyance due to differences between what people are familiar and comfortable with and what the various standards (proprietary and international) define. I recommend that everyone use one of the international standards rather than some “comfortable” format. For example, use ISO 8601 (yyyy/mm/dd or yyyy-mm-dd) for all dates. Happiness will follow.