Default email path in LO7.4.2.3

I’m using Ubuntu 22.04 and Thunderbird as my default email client. Thunderbird is my default email client in the OS. It has been since I installed it. In LO I click through Tools | Options | Internet | Email and set the path to Thunderbird as /usr/lib/thunderbird/thunderbird. The problem is that Thunderbird never opens. If it was already running, you’d expect it to open a new message when you click through File | Send | Email Document. I have setup in Tools | Options | LO Writer and it fails to connect to the smtp server. I have tried ports 25, 465, and 587 with TLS/SSL checked. I can get a network connection but fail to connect to the smtp server. Any ideas?

Set up your mail account in Thunderbird.
Open some document and call menu.File>Send As > Document. This should start a new mail in a Thunderbird window with the current document attached.

The mail account you can set up in LibreOffice is only used in spammer mode (serial letters via Email). I think, it can not handle Google’s authentification. I’m not sure since I do not use any Google services.

I would also check if the usual “snap” crap (either LO, or TB) prevents normal behavior. (Indeed, that only relates to File->Send.)

When you call menu:File>Open… can you navigate to directory /usr/lib/thunderbird/ ? If not, you have a problem with the snap container. I gave up on snap containers. I’m reluctant to configure yet another software layer.
Simply use the Debian packages privided by Ubuntu even if this will not be the very latest version. Or download the Debian packages from, extract the package, open a terminal and

cd ~/Downloads/LibreOffice_7.4.2_Linux_x86-64_deb/LibreOffice_7.4.2.3_Linux_x86-64_deb/DEB
sudo dpkg -i *.deb

assuming that you extracted to LibreOffice_7.4.2_Linux_x86-64_deb/ in your Downloads directory.

From what I’ve learned the email is sent directly from LO and does not use Thunderbird. That was a revelation. I also learned the smtp server for Google is You also need an app specific password from Google. Thanks for your clues. They led me on a research hunt.

I originally had the snap package installed. It was missing features I use in LO in Windows. It was not the “Fresh” version. I made a mistake and installed the fresh version from downloading the .deb file from I wound up with two versions installed. Then I did a rm --purge libreoffice* in bash. Afterwards after restarting, I reinstalled LO via the apt --install libreoffice. That solved my missing features. I can now connect correctly to the server but still cannot send a file via email. I don’t know why. It was like correcting one small thing after another. I think I’m still missing something.

menu:File>Send>Document sends the current document as a mail attachment to your email client (Thunderbird). This works on my system (Ubuntu/Gnome with the latest Debian package) without specifying anything in the LibreOffice options. The following hyperlink in an office document opens a Thunderbird window with a new email:

It makes no sense to setup set up SMTP in LibreOffice unless you want to send serial letters (aka form letters) via email.

1 Like