Default fonts (.doc) problem

I get Word (.doc) forms which internally seem to be really RTFs. I have to fill in the forms, convert to PDF and send the result back.

The fonts in the form seem to have fonts assigned (by number), like \f1\fs18 \cf1 and \f2\fs16 \cf1.
At first sight, there is no specific font defined anywhere in the .doc, so I suppose that the sender relies on the fact that all Word users have not changed their default fonts from their factory settings.

When I open this form in LO, the formatting is quite wrong. One example is a text box, of which the size apparently is fixed, but the actual text has been assigned a narrow font to make the text fit in the box. As I don’t have the same same font assigned, the text is wraps and is partially invisible.

How can I solve this? Eg., does anyone know which are the default fonts which correspond to /f1 and (particularly) /f2 in the RTF?
Or maybe there is a simpler solution?

Maybe unnecessary, just in case: I’m on Slackware64-current, and Libreoffice is

There was a more generic writeup of this problem, but no solution was proposed, and I suspect I could solve my problem knowing which default fonts correspond to the ones referenced in the .doc.

EDIT My apologies - a black hole absorbed my vision, it seems. On the second line of the .doc, this line specifies the fonts:
{\fonttbl{\f1\fcharset1 Verdana}{\f2\fcharset1 Arial Narrow}}

So, that solved my font identification issue. The resulting PDF seems to format correctly too. How can I make this automatic now? I.e. how do I link the /f1 and /f2 to verdana and arial narrow. For now, I changed the character sets manually. Can I make this the default when opening .doc documents?

This post might be helpful:

Replacing Microsoft Fonts

Thanks! Will read up and report.

I must be doing something wrong - no substitution is done. I added a new entry to the font replacement table, changing Arial Narrow (the entry for f1) point to Archivo Narrow. The Apply button didn’t help, so I also tried to reload the document, and restart Writer. There was a font for Arial Narrow installed, so I also eliminated that one. Suggestions?

I’ve submitted a bug report - The problem seems to be reduced to LO not importing (or interpreting) the font names from RTF files (all names are imported as ‘0’). Defining a substitute font for ‘0’ works, but there’s no way to distringuish between fonts.