Default style sometimes shows as bold - why?

H all,

I’ve got two paragraphs which (as far as I can tell) have identical style.
However, when I reset para 1 to default style, text becomes bold. When I reset para 2 to default style, it’s not bold.
So there must be some other style information lurking somewhere - any ideas?

Many thanks,

If your first paragraph follows a heading with bold formatting, sometimes that bold formatting gets passed on to the next paragraph. That’s a very old bug. Another possibility is that you once applied boldface to the first paragraph as direct formatting, then applied a paragraph style with bold formatting, thus hiding the direct formatting. Direct formatting overrides paragraph styles, so when you later apply Default, the original bold formatting pops up again. Select the entire paragraph an press Ctrl+M to remove all direct formatting, be careful if you have any other formatting applied, like italics, capilalisation, subscript and the like.

Hi Floris,

many thanks. I will check this out!


HI Floris,
so yes, it may be the case the bold “leaks”, possibly also from the following paragraph.

So should ctrl+M remove all direct formatting? E.g. setting a style, then doing Ctrl+M should have predictable consequences, i.e. resetting all parameters to the style alone? I find that it results in somewhat random results, with either bold or italics creeping in, which can change with an undo/redo cycle.

Any tips?

Ctrl+M should only apply to selected text. It will remove direct character formatting from the selection, and direct paragraph formatting from all (partly) selected paragraphs. You should use styles for formatting instead of applying direct formatting as much as possible. When you have a badly messed up document with lots of direct formatting in it, In that case copy+paste in a new, blank document may help cleaning up.