Default to print notes in margins leaves blank spaces when no notes

I have set the notes to print with tools–option–LO Writer–printer. This works fine when there are notes.

However, when there are no notes, it still reduces the text and makes a blank space for them. Thus, I still need to remember to manually change the notes setting, which is what I was trying to avoid.

I doubt that there is a solution for this but there is nothing to lose by asking. Perhaps the setting can be dealt with in an upcoming version.