Defined Ranges Not Saved In Calc

Create Defined Range via Data → Define Range, all disappear after saving and re-opening document. If I create a defined range in MIcrosoft Excel and open it in OpenOffice Calc, they appear fine.

Tried saving in ODS, Microsoft Office (XLSX) and OpenXML (XLSX) formats, all had same issue.

Calc Version:
Build ID: 00m0(Build:5)
Locale: en-US (en_US.UTF-8)

chentiangemalc@lxle007:~$ uname -a
Linux lxle007 3.13.0-63-generic #103-Ubuntu SMP Fri Aug 14 21:42:59 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I hit the same issue. Quite disappointed; I had more faith in LibreOffice than that.

I have recently installed LO v5.1.3.2 (x64) Calc with two different ranges in one worksheet and use those range names as part of a LOOKUP formula in cells in a different worksheet within the same workbook file. Works great when first created, however when I save and close the workbook file and later open it the formula changes to =NA() because it has lost the ranges. They are NOT displayed in the Data > Define Range > dialogue. Retyping formula - tooltip auto completes range but it does not work

I have the same issue. Anyone know if it has been solved yet?

I am having the same problem with Version: Hoping someone will see this thread and get the info to someone who can answer, and/or fix this.

Wow, Three years later and even in version this is still unresolved. What is the point in having a feature like this which doesn’t survive a save? Windows 7