Deleting Hyperlinks

How to delete a hyperlink in a spreadsheet cell? LibreOffice is adding them automatically to email addresses. The UI enables editing the hyperlink, but not removing it.

Please re-open the question, since the answer does not work.

This is a bug that has been reported repeatedly here and here and more. Please add your vote and voice to those bug reports to get them fixed.

Right-click the cell, then “Clear Direct Formatting”. This will also reset all formatting you might have applied, but it will remove hyperlink.

If you want to permanently disable automatic hyperlinking, go to ToolsAutoCorrect Options, “Options” tab and uncheck “URL Recognition”.

I’ve just upgraded to Mavericks and using Libreoffice I used to be able to remove unwanted hyperlinks with ‘clear direct formatting’ but that no longer seems to be effective, and my ‘URL recognition’ options are unchecked. Any ideas?

It’s 2017, LO on Ubuntu and this is still the case. “clear direct formatting” does not remove the email hyperlink.

Thank you; apparently I can also “select” the links and then right-click on them and choose to UNlink them.

This doesn’t work in my version of LO ( When I right click on the link, I see this:

I see the “Clear Direct Formatting” option as described above, but no “UNlink” option.

Hello; I am NOT using a spreadsheet; just a page with 10 table cells, each for a business card. I have my URL and my email addy on each card but do NOT want them underlined as links. How can I remove the linking please? I can email you the odt file if that will help. Thank you!

Delete your URL and email. Press Enter a few times to create empty lines.
Paste your URL on the first line and DON’T press Enter. Just use the cursor keys or click on the next empty line and paste the email address.