Dependency issue on install... Help please


I’m a RHEL 6.4 user and last week I tried to upgrade my LibreOffice 4.0.4 to 4.1.0.
Once downloaded and untar, I use the following command to launch installation “yum localinstall *.rpm”
Problem, each and every time I got this error that stops the installation :

—> Package libobasis4.1-writer.x86_64 0: will be installed
—> Package libobasis4.1-xsltfilter.x86_64 0: will be installed
→ Finished Dependency Resolution
Error: Package: libobasis4.1-core01- (/libobasis4.1-core01-
Requires: libreoffice4.1-ure
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest”

Of course the /RPMS folder contains this one : libreoffice4.1-ure-

I tried to download the installer from different sources for nothing, they all were the same.
I tried reinstalling with the suggested arguments with no chance.
I tried reinstalling my old 4.0.4 and now I got the exact same error.
I’m missing my LibreOffice badly now… Hope someone will have a solution.

Thanks in advance.

I had similar situation today… I updated LO from 4.0 to 4.1; and then removed 4.1 with command lines… afer that, I wasn’t able to install LibreOffice. I fixed it this way: try to install “sudo apt-get install ure” and if some dependencies issue occur, just try to install them with the same command (instead of “ure” write that dependency). I changed in Synapic Package Manager Forced Version of URE to 4.0… and then I was able to install it :slight_smile: However, I am not expert.

So I just tried to do it your way but without success so far, unless I had a wrong understanding of your answer :

[root]# yum search libreoffice4.1-ure*
Loading mirror speeds from cached hostfile
Warning: No matches found for: libreoffice4.1-ure
Warning: No matches found for: libreoffice4.1-ure-
No Matches found

well, I am using Ubuntu…

I had the same problem with RHEL. I resolved it using the rpm command instead of the yum localinstall

sudo rpm -Uvh *.rpm