"detailed calculation settings" won't stick

In options->LO calc->formula when selecting the custom setting for detailed calculation setting it doesn’t “stick”. I need the setting “treat empty string as zero: false” to be in effect. Is this option the default option?? It is automatically reverted to the default setting when I reenter the options menu. This is highly annoying since I have a rather large spreadsheet littered with random empty strings that I don’t want calculated as zeroes.
Any solutions?

(LO calc vs, Mac OS X 10.9.3)

Just to confirm (I assume you did): do you save the settings using ‘apply’ or ‘OK’?

There is no “apply” button, only “ok”, “cancel”, “help” and “revert”
The problem is that empty strings are treated as zero