Dictionary not shown in Language Options/Settings

LibreOffice version; running os Fedora 26 fresh install.

already tried;

Tools → Language → More Dictionaries Online.
This opens up the LibreOffice site , search Extensions. Drop down menus say the following.

went looking on the LibreOffice.nl site and found a tar containing a bunch of dictionary files. So decided try that route.

Then i double checked if the location of the dic file was correct or if there was a third option.

  • rpm -ql libreoffice-core.x86_64

Looked inside LibreOffice → Tools → Options → LibreOffice -->Paths
The location for Dictionaries stated
That’s the location i found using rpm -ql
Of course i tried restarting LibreOffice Writer. This being the second day when i decided to ask the community for help.
i rebooted my wife’s laptop so everything is restarted.

i frankly don’t know what’s left to do???
i expected option 1 would work inside Writer adding a language. But option 2 should be the solution not the easy one and not one i would like to see new users having to use but still it doesn’t work what else am i supposed to do now ?
My mission was switching my wife from Windows to Linux and in my case Fedora because of my work with Centos.

Any help would be very much appreciated.
i read a few questions similar to mine but none with the same in depth version numbers and what the person tried before asking others. So it’s not clear if he/she tried everything i tried.
Thank you all.

I don’t know RPM based systems, but to add a dictionary under Ubuntu, I did the following:
sudo apt install -y hunspell-en-gb libreoffice-l10n-en-gb hunspell-en-za libreoffice-l10n-en-za

I think you could probably do something like that with the appropriate RPM command and dictionaries.


Thanks Derek,

in my quest to fix the problem i thought about hunspell midst all the teeth grinding and being madd why i did not work. using extensions…So i forgot all about it …
Thanks mate it did the trick.
on Fedora and Centos,red hat system it’s pretty easy.
dnf install hunspell-nl
GB and US where already installed on my system (oeps hahhaha)

You must install dictionaries as extensions. The method you have chosen is totally wrong. By the way, where did you learn it?

Thanks for your answer but i already tried that. if you read my explanation point 1) where i tried to install the dictionary using Extentions you’ll see i was not able to find the Dutch dictionary extension my search was for every possible way to write dutch.
After that didn’t work i simple started hacking and trying to find a work around. So option 2) was my way of trying to make it work.

Indeed, the LO extensions site does not include a Dutch dictionary. However, the AOO site does.

I recommend installing LibO again, but only as “Modify.” Then on screen after clicking “Modify,” click on “Additional User Interface Languages” and click the languages of choice.

Did you read the question really?