Different spaces between text and footnote separators

Build ID: 1:6.0.7-0ubuntu0.18.04.10

Hello fellow Forumers!

My thesis has 100 pages. Not all of the pages contain footnotes and therefore there are less than 100 footnote separators. Spaces between text and footnote separators are not identical. Sometimes it is like 3 lines of text, sometimes like 2 lines of text, sometimes like 1 line of text. Several separators have no space between text and footnotes and it looks rather bad.

  1. Is it a mistake to have different spaces between text and footnote separators?

  2. How can I make all of my spaces between text and footnote separators identical?

Wish you a good health!

You need to ensure that your footnotes all have Footnote paragraph Style.
When pasting in footnotes, I always paste unformatted text only ( I added icon to Standard Toolbar) as it is easy to paste a different paragraph style accidentally.
Open the Sidebar > Styles, and then select one of the odd-looking footnotes and double-click Footnote style in the Sidebar, the footnote will immediately conform. Repeat with others.
Any bolding you may have applied will be lost unless you applied Emphasis character style, Hyperlinks will be unaffected as they have the Hyperlink character style. Cheers, Al

Do you save .odt or .doc(x)?

@EarnestAl: applying a style does not clear direct formatting; so, this may not be enough to get rid of spurious formatting. Some Ctrl+X on notes may ne needed too.

Yes it doesn’t get rid of direct formatting but the normal issue with footnotes is a different paragraph style gets applied when the note is pasted from its source.
Certainly, if nothing happens then select the notes and press Ctrl+M

How can I do this in LOWriter? I do not see no “Foonote position” option.

If you set the footnote position to “Below text” instead of “Bottom of page,” the space between text and footnote will be uniform, but the bottom margin will not. This is a choice you have to make

Source: Improving the Bottom Line

@ajlittoz I save .ODT.

@EarnestAl I did not paste my footnotes because I use Zotero. I can set the minimum distance to the text in Format-Page-Footnote (the default value is 1 mm). It solves the problem of “no space between text and separator”. However it is impossible to get equal spaces between text and separators in LOWriter.

Zotero uses its own principles to gather and store data. It then launches a set of macros to try and integrate into Writer (remember Zotero is supposed to work with a variety of document processing applications and consequently developed its own idiosyncrasies to “avoid” portability problems). Notably, Zotero direct-formats (through macros) all its data and you won’t be able to fix anything with styles. This is the main inconvenience.

I have already met many issues with Zotero due to the different paces of evolution (said it differently, Zotero can’t make it up with Writer changes and anyway won’t bother to better integrate with Writer because it could break other markets).

Unless you have good reasons to use Zotero, despite all its qualities, work with built-in Writer features. If your concern is only with footnotes, use Writer footnotes.

An ancient post (2012) is probably no longer relevant but Footnote Formatting: Thick and thin separator lines? is similar. It seems the answer back then was to click apply in Zotero and if OK click OK or something. I don’t have Zotero to interpret.