Digitally Signing the document issue (what is NSS Certificate DB)

Using the latest stable LibreOffice Writer on latest, upgraded Ubuntu 12.04 64 bit

I was playing with Digital Signatures.

I don’t know which password to provide in the box: Enter password to open file: NSS Certificate DB

I tried to provide my own password (primary user with sudo access) but it’s not working!
I tried not to provide a password - the same.

Here are the steps how to reproduce the error my issue:

  1. Create Writer document and save it
  2. Click on FileDigital Signatures menu item
  3. Click on Sign Document…
  4. You will see the popup asking the password (see above)

What is that NSS Certificate DB File and what is the password?

LibreOffice uses Mozilla’s certificate management system/database, so it asks for your Mozilla/Firefox/Thunderbird certificate-store password.

In my version of Firefox, you’ll find the certificate manager in Edit|Preferences → Advanced → Encryption → View Certificates.

Other Version might have it on the Security or Privacy tab.

To sign documents, you need a x509 certificate, if you don’t obtain one via a certificate authority (verisign, startcom, CAcert, … there really are a lot),
you can create a self-signed certificate using openssl (there are numerous tutorials out there)
Many tutorials however focus on creating the certificates for use with a webserver, and thus are a little more complicated than necessary. Don’t be put-off by walls-of-text :slight_smile:
It basically is just three steps:

  1. you create your own CA (certificate authority)
  2. you create a certificate for actual use
  3. you sign that certificate with the CA you did create in step 1 is one of the less verbose ones and has commands you can copy’n’paste.