Disable "autoselect object"/object handlers when releasing mouse button or lifting pen

Suppose you have the freeform tool (or other tools such as line, geometric shapes, and similar) permanently selected; that is, you double-clicked on its icon, so that after drawing the selection tool is not activated.

You draw a small object – say a very short line. Upon releasing the mouse, or upon lifting the pen if you’re using a stylus, the object just drawn appears selected, with handles on edges & corners.

If you have to draw a new object that is enough far away from the first one, then it’s no problem: the freeform tool is still selected and the drawing proceeds under your mouse or stylus.

However, if you want to draw a new object very close to the first one, then Libreoffice interprets this as you wanting to transform the first one, which is still temporarily selected.

This behaviour is problematic for example if I want to draw a small “x” by hand: after I draw one line, instead of drawing the second I end up resizing the first one.

Is there a way to disable this automatic selection after drawing an object?

I have followed your procedure with the mouse, there are no problems. Drawing an “X” is easy.

It depends on the size of the “X”. Try drawing a very very small one.

You must not click on the previous object handlers. So, maybe you must adjust the zoom level.
Not sure if related, but you can take a look at menu View - Snap Guides options.


The problem is that I don’t really need to zoom in; in fact, if I did I’d need to zoom out immediately after. So this is not a convenient solution.

I’ll check the Snap-guides option and report back, thank you for this suggestion.

Tried out: unfortunately the various snapping and grid options don’t seem to help with this problem.

Can you please describe your request a little better?
Are you only concerned with the production of the smallest possible “X” and in which size should this be?
Are there other drawing constellations where you have the described problem?
Please describe in more detail what exactly you want to achieve? Thank you.

Alright. First the case without problems:
Let’s say I’ve just drawn this with the freehand tool:

Now it’s no big problem to just draw another line by moving the mouse up, left-clicking, and drawing. I must only be careful not to come too close to the green handles. I obtain this:

Now the problematic case. I’ve just drawn this new, shorter line below the larger “X”:

And I’d like to complete a little “x” by moving the mouse a little up, left-clicking, and drawing again. Try doing that, and what happens is that the click-and-move will instead reshape the previous small line. This is because Impress thinks that I want to click on one of the green handles.

So in order to get this:

I need to click somewhere far away first (and that creates an unwanted small dot), then come back near the small line and finish the “x”.

The “x” is just an example. Try writing a short sentence with letters having the size of the small “x” – it’ll be simply impossible. It doesn’t need to be a sentence: any free-hand drawing that requires small details is extremely impractical to do because of the green handles that appear whenever the mouse is released.

One solution, mentioned by @LeroyG , is to zoom in (so the lines are bigger and the handles can be avoided). But this is also impractical, as I’d have to zoom in and out all the time if I’m doing free-hand drawings all over the page.

I hope the problem is a little clearer now.

1 Like

Trying to work on small objects in any graphics program is difficult so they all have a zoom function.

  • You can zoom in on your selection by pressing the / key on the numeric keypad.
  • You can zoom out to entire page by pressing the * key on the numeric keypad

Neither of the above loses the selection nor the currently selected tool.

More Keyboard shortcuts at Shortcut Keys for Drawings

1 Like

Thank you EarnestAI. But actually it’s not difficult to work/write at the current zoom level (I have a stylus, but also with the mouse it would really be no problem). So I don’t need to zoom in to have more drawing precision.

The problem are the green handles that appear whenever I release the mouse or raise the stylus from the display. If they were not there, and the freehand function is still activated, I could continue drawing without problem and without zoom. So the point is that it’d be better to automatically lose the selection.

Hence my original question: can this “autoselect” or the appearance of the green handles be disabled, at least while the freehand tool is in operation?

Zooming in allows you to avoid the handles so you can start inside or outside them. Anything else that changes the selection, e.g. Tab, or removes the selection, e.g. Esc, also removes the tool selection

1 Like

I see. As I see it, this is a bug, because it doesn’t allow for a smooth use of the freehand tool. I’ll submit a feature request that I hope will fix this problem.

1 Like

To be fair, the tool is called “Freeform line”, so it does not seem to be meant for doing “freehand drawings”. I’ll simply submit a feature request then.