Disable heading duplication

I have inserted a heading in a page, then typed some text with default style and when there were no place on a page a new one has been created and heading has been duplicated. Can i disable heading duplication and how?

Please note that ‘Header’ and ‘Heading’ are very different terms in text processing. Your question seems to address the ‘Header’ case.

To give you a general background: in LO Writer, header and footer are attributes of a page style. The same page style applies for all apges until you change it through a page break with a new associated style. As a consequence, header and footer is the same for all pages under the said style.

The solution, as pointed out by @mariosv and @JohnSUN is to use two page styles: one for the part with the header, one for the part without. Built-in style First Page is like any other with a special attribute enabled: it is set to automatically switch to built-in style Default when page overflows.

As you can see, style First Page is not a flag for Default or any other page style, but, I insist on it, it is a mere page style. Therefore, if your document is made of several parts with the same structure, i.e. an initial page with a header and “content” pages without header, you’ll have to create other pairs of styles such as FirstPart-x and Part-x with similar properties to First Page and Default.


If your “content” pages all look the same, without any header nor footer, you can use the same style for all, e.g. Default, though it gives you less freedom should you later reconsider the absence of header/footer.