Disable mouse zoom in osx

Hi everyone,

I’ve had an issue for a while with zooming in OSX. I’ve managed to figure out that it’s caused by the mouse gesture “cmd + mouse scroll” (zoom in/out). When scrolling in OSX the page comes to a stop slowly rather than immediately stopping. It seems like if I press cmd while the page is still moving then the zoom gesture kicks in.

Is there any way to turn off mouse gestures in libre office? It drives me crazy having to constantly adjust the zoom if I press cmd at the wrong moment and I can’t find any settings to turn it off.


I think you understand that this forum is not an OSX but an LibreOffice forum and your problem has nothing to do with LibO but with your OSX. Therefore please don’t expect an immediate answer because not everybody has a Mac and the expertise to answer your question. In your case I would just search the web for the OSX related answer.

It’s nothing to do with OSX. I have never, ever, ever had this problem in any applications on OSX other than Libre Office. The scrolling thing mentioned in the answer below is also unrelated- I have ctrl+zoom to zoom the actual screen in and out, but command zoom is something that’s been added by LibreOffice. I tab between windows and then scroll, and it blindly decides to scroll to about 1000%. It’s infuriating and soon to become a blocker for me in regards to using the application.

Hi @ROSt53. Like @maffoo mentioned, this isn’t a problem with OSX, it’s not a default of the OS. It’s implemented in Libre office so it makes sense to be able to be turned off in Libre office.

Search the libreoffice bugs mailing list for scroll and command. There are plenty of filings there. Add to one instead of asking this question. Should bug reports be linked here?
Example: https://bugs.documentfoundation.org/show_bug.cgi?id=46429

This problem is NOT solved at all. A third party app that cost money is NOT a solution in any way.

You can use the following free application to setup LibreOffice specific shortcuts for cmd+scroll up and cmd+scroll down.

Better Touch Tool — http://www.boastr.net


  1. System preferences > Accessibility > Zoom… Check “Use scroll gesture with modifier key to zoom:” and choose Command. This stops Libre Office from zooming but has the unfortunate side effect of zooming the whole screen. That is easier to recover from though by Command scrolling down to normal zoom.
  2. System preferences > Accessibility > Mouse & Trackpad… Choose Mouse options and change to scrolling without inertia. This should make it less likely for the scroll to overlap pressing the Command key.

Neither option is ideal but your mileage may vary.

Unfortunately this only disables zoom for vertical movement, it is still activated with horizontal or diagonal movement :frowning: Back to the drawing board.

Hi @ehlo, thanks for the attempt. I like smooth scrolling though… I’d rather put up with the bug in libre office than turn it off. I’m still waiting and hoping for a fix…