Disable popup toolbars

Where can I find the option to disable the appearance of all those unwanted (at least by me), mostly context dependent toolbars?
On my small laptop screen the resizing of the text area every time an toolbar appears or disappears is quite annoying, besides the screen is just to small for all those toolbars I never use. Some of those toolbars just appear and never disappear again! (Navigation toolbar)

At least from the point of view of LibreOffice Writer under Windows, none of the comments answers the question:
a) Closing the navigation toolbar from the menu ‘View - Toolbars - Navigation’ does not prevent this toolbar from popping up again on the next occasion.
b ) The close button alleged to be part of the vertical scroll bar is not there, since there is no vertical scroll bar.
Thus, the question remains: How do I disable the navigation bar permanently?

(1)Wiki Help · Using Toolbars · Context of Toolbars

To Close a Toolbar Permanently

While the toolbar is visible, choose View - Toolbars and click the name of the toolbar to remove the check mark.

Example “Table toolbar” (Writer):

Set the cursor in a table cell to make the toolbar visible, then choose “View → Toolbars → click Table”.

(2) The → “Navigation toolbar” is pretty well minimized (as an icon) in the vertical scrollbar

(and has a “close” button, if undocked).

navigation toolbar

@JDG - Notebook screen space is always limited. Thus I customize my toolbars to my what I need. This gives me a lot of screen space and gets me all icons I need. I only use context toolbars very selectively (how to do: see @manj_k’s answer). Most of them I switched off.

but, how to enable toolbar permanently? For example, I use Line and Filling all the time in Impress… it is quite annoying to see it dissapering and appearing every now-and-then…

@Ljilian - My largest toolbar is the standard toolbar, which is always switched on.

The suggestion does NOT work for the Navigation toolbar and some others. This should be re-opened for comment.

I’m having the same issue with the text formatting being removed constantly even when I set it to show